1.1.2 - alpha 1 firmware

DOWNLOAD LINK:
onefinity-1.1.2-alpha.1.tar.bz2 (2.9 MB)

This is ALPHA firmware, which is tested even less than beta firmware.

The main change in this firmware is making xbox controllers more compatible. If you have an xbox brand controller and it hasn’t worked on 1.1.1, this firmware SHOULD fix that. Please let us know in the comments below.

Changes since 1.1.1:

  • Correctly handle gamepads/joysticks that have “weird” characters (such as ©, ℗, ®) in their device metadata.

  • Added a “deadband” option to the Settings panel, for gamepads

  • Fixed a minor spacing bug in the “Remaining” display

  • The default screen resolution is now 1280x720 (720P), for compatibility with more screens.

  • When upgrading the firmware over the web, download progress is now shown.

  • Don’t constantly scan for wifi. Do it once at startup, once when going to the Network page. Added a “Refresh” button in the Network page to allow the user to force a scan. This SHOULD improve wifi signal and transfer rates.

  • Added network info back to “header” of the UI


How To Install:
Updating via USB
You’ll do an update via USB using the following steps:
Copy the blue .bz2 file above onto a usb stick (it must be formatted as fat 32 or ntsf). Click the flyout menu (three bars on top left), general, under firmware click ‘UPLOAD’. Select the 1.1.2 alpha file.
If you are on firmware 1.0.8 or lower, it may ask for a password.
the password to update will either be buildbotics or onefinity

1 Like

I went ahead and tested the beta and it works GREAT!!! No more issues with stick drift as well as the controller working again!!! As usual OF, way to go!!! Thank you guys!!!

2 Likes

As per directed did the update, running a test carve now to see how things work.

Have this loaded up and everything seems to be working very well! No issues so far.

going on 5 days of using said beta and have had 0 issues!!!

1 Like

I am waiting for the dust to settle on updates before proceeding. 1.1.2 seems to be stable, when will it progress to beta and general availability?

2 Likes

Works great, fixed my controller and monitor.

Just bouncing it to the top

FYI, 1.1.2-alpha.1 has fixed my i) hanging “Processing New File” popup on reboot and ii) dead Onefinity Wireless Joystick Controller problems with 1.1.1. The machine’s wifi connection is much more reliable than it was on 1.0.9.

So 1.1.1 has known bugs and 1.1.2 alpha seems stable but probably needs more testing. What do I upgrade to?

Typically, my advice is to go with the release version (1.1.1 in this case) unless you have a known/observed issue with it (which I did, so I went to the latest prerelease).

In this case though, 1.0.9 is a known good release, so it may be best to just stay there until 1.1.2 stabilizes if you would prefer to skip drama of the known issues in 1.1.1.

I waited to upgrade to 1.1.1, hoping the bugs would have been resolved… unfortunately, for me, they weren’t. Issues, that most pissed me off, we’re loss of X and Y Zero between bit changes and unexpected monitor lock ups.

For the loss of zero, I had just finished the roughing pass on a 3d model, and proceeded to change bits to the Tapered Ball Nose, and zero for Z. When I hit play, the bit was driven straight down into the wood (better than 1/2”), then dragged, diagonally across the wood. The X & Y zero was shifted 3” diagonally from where it should have been…. As for the monitor locking up, it was the touch function that has become intermittent. I can move the mouse with my finger, but when I tap the screen, to press a button, nothing happens…. Seriously considering reverting to 1.09

Had a bunch of issues with 1.1.1.

When probing XYZ the router could just stop and freeze and never move. Screen was still responding, could hit cancel and then re-probe.

Remote browser session would constantly disconnect during file uploads and then want to re-home after re-establishing.

Had the screen freeze but the job still cut.

Moved to 1.1.2-Alpha as I wasn’t happy with these issues. Now, I can’t remotely upload a file. It says uploading and gets to 70%-ish then the box disappears and nothing happens.

Guess I will be trying to go back down to 1.0.9.

I’ve got to say, as a new owner, these issues are a little disturbing. These aren’t odd little features not many people use that are having problems. Should 1.1.1 even be out there still? Should there have been a longer, better coordinated beta process before release? Should these releases have been more limited in scope?

I know sometimes 1F explains that they’re a small company with limited resources. Perhaps that means they need to adapt a slower and/or more granular release process. I’ve been in software development since the early 90’s, and that is the tact I’d lean towards. It is much more manageable from a testing and QA perspective, easier to step back from a problematic release, and maintains better relations with customers.

2 Likes

Hi, this version works well for me, I had no issues except once in a while the homing will lock up (will not complete) and machine locks. I had the same with 1.1.1 however if I recall.

Reverted back to 1.0.9 wanting to give newer versions a try. Any advice as I cannot get feedback from the technician assigned to my case.

The update to 1.1.1 broke my ability to upload from the web interface. I was not having issues with WIFI I was able to connect to the web interface no problem, but anytime I tried to upload a file it took forever and then eventually always errored out.

I came here and installed 1.1.2 alpha and it fixed my issue.

4 Likes

I have a 1F Journeyman X-50 with a Reserved IP address directly wired to a hub and a Win11 PC connected to the same hub (connected to the LAN) to monitor and control the machine. This stopped working. Upon inspection and only after reconnecting the touchscreen it appears that Version 1.1.1 is NOT using DHCP or Reserved IP but instead 10.0.0.150/#control
WHY? Well, the world is a beta site.
I am curious to see if 10.0.0.150 works for others having this issue.
Cheers!

Hi… not sure if it helps but I had no issues connecting to the controller using Ethernet wired connection. I used the device name instead of the IP address. It seems the default name is “http://onefinity.local/#control” (you can change that once connected) and this connects well and I don’t have to worry about IP address. It also works for wifi, I use a mobile hotspot from my computer otherwise signal strength is not enough for the controller (Raspberry PI). Make sure the wifi or Ethernet connection is active before powering the controller. Works for me. Hope this helps.

2 Likes

I was looking for that address … THANKS!