Firmware Update 1.0.9 (12/17/21) (Latest Firmware)

I have updated the firmware 1.0.9 now that the tile making and Xmas projects is complete. I found an interesting thing with Lightburn when using the Jarvis or Stuki setting. If I set up to run in the Y direction it will start “stuttering is the best way I can describe it”. Almost as if the ball screw were in a bind. If I set to run in the X it does the same thing. So, I set up to run at 45 degree angle, and it does the same thing, mostly on the X it seems when running in 45 degree. I took the same file and processed it with the Vetric laser module and it ran with no problem. When moving the machine with the game controller I can not make the machine do this, I have tried it at the fastest to slowest setting. It is only happening with Lightburn files. I am going to try and get back out to the shop today and check again that I didn’t change something in my settings in lightburn with out realizing. I run all my stuff in inches across Lightburn, Vetric, and have the 1F set for imperial as well.

This may be based on arc/circular interpolation. It was an issue in fusion ad well when the default changed a year or so ago.

2 Likes

Something to think about. Would this affect straight line movements? It is only doing this on when moving in straight lines, there are no arcs or curves.

Just finished up running a few test. Took the same photo in Lightburn and set up for 4 different ways. It seems like this is generally about 2 minutes into the job.
Grey scale = no problems.
Jarvis = stuttering sounds like the machine is about to break something.
Stuki = stuttering sounds like the machine is about to break something .
Ditther = stuttering sounds like the machine is about to break something.
The same photo in Vetric laser module with the same settings for grey scale and ditter.
Grey scale = no problems at all.
Ditther = no problems at all.
Checked Lightburn, but can not find any settings that I might have changed and not realized. Also Line and fill settings in Lightburn are just fine with no problems at all.
To insure that it wasn’t just the photo, I selected a new photo and ran these tests again, and had the exact same outcome. I’m stumped. For the time being I can not use Lightburn, or burn any more tiles.

Is the gcode file a substantial difference in line count? I am curious if it similar to the interpolation idea is doing hundreds of short moves (maybe in the same direction) instead of a single movement.

1 Like

If you still have the files, flash back to 1.0.8 and see if you can reproduce the same results.

2 Likes

@Hermsen.BJ Don’t know why I didn’t think to look at line count, tired I guess. I will try to get out and do that today. Thank you.

@OnefinityCNC I will give this a go. If not today then tomorrow at the latest and post results here. Thank you.

I installed 1.0.9 without any problems. I tried a test cut with my makita, no problems. I went to try my j-tech laser and couldn’t find where to turn of the dynamic power so I could use the M03S20 mdi command to give me a low powered beam to locate my zero point. I did a test cut with two circles at different powers and the dynamic power is on. So where do you turn it off or is there and mdi command to turn it on and off?

You don’t turn off dynamic power.

So how do you turn on the beam at low power so you can move it around with the game controller? M03S20 did that before, no beam now. Don’t tell me you got rid of that option.

try S25, S30, etc… The scale is now 0-1000 so S20 use to be about 8% power on the old 255 scale if you had not updated, now it is 2% power on the new scale.

Thank you. As soon as I read your reply I fired up the laser and tried S80. It worked. I guess I missed or didn’t understand what the change in scale would mean.

1 Like

From the changelog above:

  • Fixed Laser issues with homing, mdi, zeroing, and jogging while using mdi to find zero for laser.
  • Added new configuration drop down (Makita router and @JTechPhotonics laser are now preprogrammed in the ‘tool’ list). Moved all VFDs to ‘unsupported’ list.
  • Changed pwm spindle speed for jtech laser from 255 to 1000. Since spindle speed is increased, you will most likely need to increase the S value (m3 sXXX) you have been using in the mdi command to fire the laser. This S value should be anywhere from 1-100 (100=10% power).
1 Like

Sorry for the delay, been a busy few days. I just came in from flashing back to 1.0.8 firmware. It was doing the same “stuttering”.
I ran the laser, burning tiles, around 80 tiles, for X-mas, then upgraded to 1.0.9 when it started doing this. After now flashing back and it doing the same thing. Vetric laser module however is not having this problem at all.
I again set up a test using the same photo, DPI, speed, direction of (set to run in the X direction), and the Ditthering setting. After about one minute with the Lightburn file it starts to do the stuttering and then just gets worse.
Running the Vetric laser module file, nothing, it just runs. I was ready to accept that it must be something with the machine itself, until I ran the Vetric file with no problems at all. I am stumped.
While running these test I did not turn the laser on, as that has made no difference at all.
At this point I believe I must have a setting somewhere in Lightburn that got changed, but I have no clue as to what.

It would be helpful to save and label all the files, gcode, and findings and send them to lightburn. They have our controller, so they may see something.

Do you have the onefinity set up as grbl m3 in lightburn?

1 Like

I will still have the files, and will see about getting them to Lightburn. As for grbl m3, it should be, but I will double check tomorrow to make sure.

As a side note, that fact that you folks at Onefinity are paying this kind of attention and responding this quickly, just WOW! Thank you.

1 Like

Do you have a firmware roadmap of planned upgrades? I am hopeful for a couple changes that will change how I use my 1F and I don’t think I am alone. 1) This may require a hardware change, unless the 2 Y motors can be run off of the same driver, but would love the addition of a 4th Axis. I have seen the split connection off of a single driver before on other machines so I think that it is technically possible. 2) Ability to adjust feed rates in XY and Z while a program is running. I think is goes without saying how incredibly necessary this is when trying new cutters and stock. Having to stop, make F & S changes, re-calculate the tool path/s, save the tool path/s, load the tool path/s, and start again, is a huge efficiency suck. It would be a huge efficiency boost if you could start with conservative values and crank it up after hearing the cutter through the stock. This is a standard function on the competitions machines and Mach1 user built.

I am quite sure, that these 2 shortcomings, would be just enough to push a prospective buying toward something else.

I think a public roadmap of features as well as a catalog of known issues (and workarounds) would be great.

To that same point, I would recommend that since there is a github repo for the firmware, that we start having folks leave firmware specific issues there, rather than on this forum.
This forum is great for CNC discussions, but technical questions are missing context that lives on github.
That may also help spur open-source contributions and help the OF team scale better.
Assuming that’s something that would be appealing for them.

Just my 2 cents.

2 Likes

Has an interesting thing happen to me today. Was running a file with the laser, second run of the same file that I ended up running 4 times to make a set of coasters. First one ran fine. Second one was down to about a minute and I turned around to do something. A few minutes later I realized the machine was still running. Went and checked on it and it appears that it started to run the file again with no action from me. The time remaining showed some odd characters, not a time anyways. Pressed stop, ran the next 2 fine. Didn’t hurt anything as it was late I was working with. But if this happens when running a file with the router it could be a big problem.

Not sure if it’s related to firmware upgrade or just a one off for some reason. Just thought @OnefinityCNC might want to know.

Thanks!

@OnefinityCNC wondering if it would be possible to fix a small bug for the next firmware update. When switching back from laser to Makita in tool settings the controller holds the rapid on-off setting when tool enable is in use. I quite frequently laser first and then switch back to the router to finish the project, it would be very helpful to not have to restart and rehome after switching back to the router.

Thanks!