Firmware Update 1.0.9 (12/17/21) (Latest Release)

Wait it out and see if it updates.

Thanks for the Maac tip ive been racking my brain trying to get it to update since wifi was unsuccessful

1 Like

I have let it attempt to update overnight but nothing happened. There must be a process issue? My Controller is connected to my PC via an ehternet cat5 connection, my PC is connected to the internet via a wireless connection. I have tried to initiate the Controller update when I am connected to the internet and then switching to my Controller Ethernet connection and that didnt work either. I am not sure what to try next. Can you help?

That’s why. When using the onefinity connected directly to a computer with cat 5, the WiFi must be turned off for it to work. Upgrade via usb stick.

Ran a job last night that started with a 1/8 bit, then changed to a 1/4 bit. The 1F paused when the 1/8 pass was complete, but I still had no control of the router Z height, so I couldn’t raise the router to change the bit or re-probe Z. Am I mistaken in my assumption that I should be able to do this?

Hey Watkins,

if the ‘tool-change’ field in the General Configuration Tab of the Onefinity Controller only contains

(Runs on M6, tool change)
M0 M6 (MSG, Change Tool)

then it does nothing more than exactly this: Displays a message to change the tool, stops the spindle, but it does not raise Z to allow it. But of course you can enter a tool change routine into this ‘tool-change’ field, it is made for that.
An example would be:

(Runs on M6, tool change)
M70
G21
S0
M0 M6 (MSG, Change tool and attach probe)
F100
(probe to minimum z soft limit, which is -10)
G38.2 Z-10
G92 Z15.4
g0 Z30
M0 (MSG, Remove probe, start spindle)
M72

See here for explanation of the G-code commands used here, more examples for tool-change routines, and more information. It allows e.g. tool change at home position or like with bitsetter or different things that you can imagine or create.

However jogging around in x,y,z during tool change event (M6) or during pause is not yet implemented.

It is a feature requested

4 Likes

You cannot jog during bit changes. You must separate each bit into it’s own file.

“Fixed ‘Disconnect’ when job is stopped or first tool is finished and waiting for a tool change” this is not a fix for what you’re describing.

1 Like

Hey Onefinity Support,

What does this fix description mean? I didn’t understand it too.

Hey Onefinity Support,

ah okay, this issue,

I was not aware that “Disconnected” appeared on tool change too?

1 Like

Thank you. I guess I don’t understand the “waiting for a tool change” part. How would I do a tool change without re-probing z? Is this just a conflict between the gCode and the capabilities of the 1F controller?

Unless you huild a custom tool change macro, you split each tool to its own file and the you prove z before starting each file. It works really well and while I like the idea of pushing go and switching bits with a prompt I feel the separation of tools to files is cleaner and less prone to risk/failure for me.

4 Likes

Thank you. Just wanted to make sure I was understanding correctly.

I recently upgraded to 1.0.9 and all else seems to be running well; however, I pressed Pause to interrupt a job, then Stop and that ended my ability to do anything else. I was forced to reboot and lose material position. Is this combination of key presses not allowed? I tried without success to move with MDI, joypad, probe, open files, etc. I have not re-tried to see if I can repeat the lock up.

1 Like

trying to update via USB and i put both onefinity and buildbotics and it comes up with wrong password or bad firmware

1 Like

Hello Adam,

  • Are you on a mac, windows or Linux?
  • Is your USB drive properly formatted?
  • Did the file download properly/completely?
  • Do you have caps lock on by accident?

windows, formatted, got the update from the link above, no caps lock

Is it a USB 2.0 stick? USB 3.0 will not work

I am using a USB 2.0. Would be alot easier if it would stay connected to my wifi like everything else is where the cnc is located

Hey Jim,

Even if it is repeated again and again, this is not true. USB 3.0 flash drives work perfectly on the Onefinity Controller, because every USB 3.0 device is downwards compatible by design.

What might not be supported because of the age of the underlying Operating System in the Onefinity Controller, is exFAT Filesystem found on practically every USB drive bigger than 32 GB nowadays. If your flash drive is not recognized by Onefinity Controller, you have to reformat the flash drive using NTFS or FAT32 instead.

1 Like