Journeyman Makita router stopping

Hello all My setup is a Jouneyman fw 1.09 makita router controlled by pin 15 on the breakout board through a ssr relay.
Using Carveco maker / onefinity (mm) post processor.

When running a drilling toolpath, the router stops after each hole is finished , so on a part with 4 holes the router will stop/go 4 times while travelling from hole to hole… If multiple parts on the same job, it will do the same thing for each holes of the different parts…
When running a contour toolpath with multiple part the router will stop while travelling (rapid) between the parts…

In the tool config the makita router with Lo/hi selected.
I also tried in the tool setup « pwm » with same results
Also in Carveco there is 3 differents postprocessors in milimeters which I have tried with same result.

Is it normal that the motor is stopping like this?
I there a setting to modify to keep the router running until the end of the job?

Don’t think that I normal.

I used a woodworker with Maker+ and a IoT relay. So different products but pretty similar to your setup. Never saw it stop like that. I used the No tool change post processor.

Hey mgollain,

if your CAD/CAM program Carveco Maker with Onefinity Post Processor inserts a lot of M3 (start spindle) and M5 (stop spindle) commands, then it means it is intended. In this case, as the software operator, you got to find the option on how to disable this in your CAD/CAM program (e.g. to let the milling motor run on rapid moves.). So I would search for M3 and M5 in your g-code to see if this is the case.

I don’t know, since I don’t know and I don’t run this program. But as the operator, you could read the manual or watch the video tutorials. Maybe someone who runs Carveco Maker can answer this, so I would ask in the Carveco Maker forum: How to disable disabling the milling motor on rapid moves?