Onefinity CNC Firmware 1.4.0 (5/24/24) (X-35/X-50/Pro machines w/ Buildbotics Controller) Macros & File Management (Latest Firmware)

I suggest that in the future when you tell someone to Reset, you also tell them to save the configuration in a json file. I lost more hours of time trying to get my machine working again. Also, the problem went away for about 8 cuts and then started up again:

I am trying to make a new spoiler board. It is cut to be smaller than the actual cutting size and positioned inside a rectangle I cut using a v-bit to show the maximum cutting positions. I made the spoiler board 47 3/4 x 31 3/4. I cut all the holes and now want to cut slots. I ran the solt cutting code on a test piece, and it worked perfectly. So I mounted up the new spoiler board and now get nothing but errors.

I will save my config and reset the machine one more time. However, should I be going back to 1.3.1 to avoid these problems?

Did you reset your configuration and tell the controller which machine you have including which z slider?

I am currently running firmware 1.0.9 and I was thinking about upgrading the firmware to the newest version (1.4.0), but I am not sure. It seems like people are having problems with the new version also. Another thing is do I have to download all of the other versions to get the fixes before I go to 1.4.0?

Yes, twice. I have it working now. I made the spoiler board even smaller. So it is about 47.75"x31.75".

I was making a test surface cut and I kept getting way too much surface removed. After checking software and rechecking my methods, I had a thought: What if the probe block is not the same size as the firmware thinks it is. And sure enough, the probe is thinner by around 1mm and shorter on each side by less than 1 mm. Now, when I surface, I’m taking off what I intended.

During this surface test I hit the Stop button (square). I made an adjustment to the Probe settings and went back to run th etest program. It was gone. Deleted. That’s a bug.

1 Like

There is a pretty basic defect with the file deletion nobody has listed on this thread. If you have a file uploaded in a folder with the same name as another file in the default folder (and I assume any other folder) it deletes both. This is a pretty basic coding miss. If you are allowing files to be stored in folders the context of a delete should be the file you selected to delete. These are sadly the type of issues that lower our faith in the black box controller updates. While as an original early adopter I still stand behind this controller as it is right for my needs, this type of miss is very disappointing. These are the logic flaws that college students drop letter grades over.

1 Like

Good to know as I rebuild my entire file library on the controller as the update deleted all my files. Generally I have a unique name for all files CNC (g-code) related as each one serves a unique purpose.

1 Like

New alpha firmware released! 1.4.1!

@Kanova802 Check out the new 1.4.1 alpha :stuck_out_tongue:

We’ve made the @DEV_S aware of your issue.

While we do our best to make sure releases are bug free, we do listen and respond to constructive feedback and make the changes when applicable.

2 Likes

Hi @Hermsen.BJ , thanks for the feedback. We will look into it and let you know the updates. Thank you!!

2 Likes