Upgrade to v 1.1.1 message

Hi @OnefinityCNC - my machine is continuously displaying the message “Upgrade to v1.1.1”. I assume your software is doing some sort of “phone home” check-in at boot time which includes interrogating my current version and then telling me I should upgrade. Since you are recommending that people do NOT upgrade to v1.1.1 can you stop displaying this message?
Screenshot 2022-12-15 103430

1 Like

Not currently, as if we remove it from github and users are on 1.1.1 or 1.1.2 it could break everything.

We’re working on a solution.

1 Like

Could someone explain what it is exactly the reason for not upgrading? What is the harm done?

@tgunr Dave, check out some of the other threads. There are a lot of little bugs in 1.1.1 that make it actually a step backwards. Kudos for 1F as to just coming out and saying “Stay on 1.0.9”. It’s unfortunate that just removing the little “Upgrade to v1.1.1” icon isn’t as easy as it sounds.

Can’t wait for the new firmware. I’m so tired of rebooting and losing everything. Look around on the forum and you’ll see some tricks for making it happen less often. (Use the Z+ for a quick jog, waiting for the buffer to clear before pressing any other buttons, etc.). However, it’s still happens far too often.


Flash back to 1.0.9 and you wont have the issue.

Hey Dave,

@OnefinityCNC I never left 1.0.9. If I stop a cut and jog the router out of the way to get a view at something that’s not looking right to me, I get stuck in the ‘permanent jogging’ issue which I thought was a known bug. Is there an easy fix to that?? Thanks for the help!

@OnefinityCNC I am also still at 1.0.9 and I would not characterize this as rare. I would say at least 75% of the time I press Stop before the program is done, I am left in “jogging” state and unable to do anything. This happened to me yesterday because I forgot to put the dust boot back on after changing bits. The program had barely started, not even carved anything when I pressed stop. I ended up having to reboot, and re-zero all axes which is a huge waste of time.


Just happened to me again just now. Maybe I’m just not waiting long enough as per the link above.

@OnefinityCNC Will this theoretically be fixed in 1.1.3?

It was theoretically fixed in 1.1.1/2.

It’s still being reviewed.

1 Like

I was able to run a little file above the piece. Once it was done I could jog again.

1 Like

Hey Robin,

you could uncheck this setting on the ADMIN page:

and then reload the CONTROL page. The “Upgrade to 1.1.1” message will be gone.

The other solution would be to make sure in your router network configuration that the Onefinity Controller is not given the default route to the WAN.


Thank you, @Aiph5u. This is exactly the info I was looking for. Too bad Onefinity support could not provide this answer. Oh well, I guess that is why the community support is so valuable!


@Aiph5u Nice catch! Good solution for those that are familiar with the machine but the banner is still sure to catch newer users. However, I’m happy to be rid of it.

1 Like