1.4.0 Alpha 6 (Macros update, now with FILE MANAGEMENT! )

Nasty surprise!
I found that when upgrading from 1.4.0a5 → 1.4.0a6 all of the macros I had created got wiped out.

When going to ADMIN tab and saving configuration, the JSON file that’s produced logs the names of the macro files but not the macros themselves. What possible purpose could this serve?

“Save Config” should include the macro code and have the ability to restore the macros -OR- there should be an option to save/download macros to a local file on a PC through the CNC web interface.

After I recreated the macros, I had to get into the bowels of Linux and tar (backup) the files so this wouldn’t happen again. That might be a bit much for a lot of users unfamiliar with Linux to get into.

Just sayin’

@tjp52 Sorry you got bit by that fresh flash backup restore macro issue too! I reported it a few alphas ago here

I have only dirty updated since that happened, flashing new alpha firmware using the browser UI without resetting. That’s not recommended, but it has worked for me. I ran a few more hours of laser and spindle projects this week on 1.4.0a6 as smooth as butter.

I am not asking you to support after market spindles, this copy paste reply is not helpful as it is used all over without addressing the context of the question or comment.

What I am asking is whether the macros can support changing between the opion that is selected in the tools menu. This would be quite helpful. Please realize I am not asking you for help with the spindle itself just with the control in the interface that you provide. It could be between makita router and laser, it could be other tools in that menu and laser.

This is also helpful in the context that the weight of the 44w laser causes me to need more conservative jerk and accel settings than the makita does.

I agree having an easily swapped config option or favorites would be great

I’ve noticed what I think is a bug. I use g53 commands to “park” the router at the back of the cutting area when a job is complete.

This works fine when actually running the job, but the job estimation/simulation doesn’t seem to understand what a g53 command means and constantly says my toolpath is over the axis limits even though it isn’t.

Any thoughts?

1 Like

Hey Bill,

it’s an (older) bug. See here.

2 Likes

I see we’re thinking the same thing :slight_smile: .

I was trying to figure out how to submit a bug report, but couldn’t find out where. Do you know if there’s a link to submit a formal bug? Or is that something only Onefinity employees can do?

Either way, thanks!

Hey Bill,

yes, you can file one here

1 Like

What is the macro g code command to run a g code file that is loaded into the controller?