Machine is looking for probe after probing

Looks like Buildbotics has a Fusion post processor in Git - will that work?

It will, but I think it will ask for probing before every toolpath.

I have the same issue here. I have tried deleting and re-adding the files after a power cycle but without luck.

its how the buildboitcs post processor is written. We’re still waiting for fusion to get back to us with updated post Ps. For now, we suggest saving each toolpath as seperate files.

Well I only have one toolpath.

Using that post processor, it will ask for probe every time. Delete the line of M6 in the gcode and it will remove the probe request.

I have no G6 line in my gcode. weird .

%
(WASTEBOARD SURFACING -0.5MM)
(MACHINE)
( VENDOR BUILDBOTICS LLC)
( DESCRIPTION BUILDBOTICS 4-AXIS CNC CONTROLLER)

(Simulation Data)
(STOCK/BLOCK, 762, 802, 19, 1, 21, 18)
(FROM/0,0,16.000)

(Tools used)
(T1 D=26 CR=0 - ZMIN=-0.5 - FACE MILL)

N10 G90 G94 (Absolute distance mode; Feed in units per minute)
N15 G17 (using XY plane)
N20 G21 (Metric Units)
N25 G0 G91 Z10
N30 G90

(FACE2)
N35 M9

(TOOL/MILL, 26.000, 0.000, 8.100, 0.000)
N40 T1 M6
N45 S15000 M3
N50 G54
N55 G0 X777.9 Y-17.115
N60 Z16
N65 Z6
N70 G1 Z2.1 F1000
N75 G18 G3 X775.3 Z-0.5 I-2.6

Oops. I meant m6. By the t1 line

Hey, I am having the same issue where I am asked to reprobe z after probing XYZ. I am using carbide create. Sometimes once I hit play the z access slams down into the waste board. It’s actually gone into the touch plate before and broke the bit. Now I add the touch plate after hitting the play button to see how low the z access will go. Sometimes it doesn’t go all the way down but sometimes it does. If it doesn’t go all the way down I can stick the touch plate in but sometimes it will e stop if it doesn’t find the plate in time. Has anyone else encountered this issue?

Are you using the grbl post processor?

I’m taking the Gcode directly from carbide create and putting the file onto my machine with a flash drive. Is that what you mean? Sorry this is my first cnc machine. Still trying to figure things out.

1 Like

This worked! Thank you!

1 Like

So it worked the first time and now it no longer works. When I hit play it goes to holding state program pause. Any ideas how to fix this? I checked the post processor and it is the basic Goode. I have probed XYZ. Nothing is showing in the MDI tab and I rebooted and tried again and that did not work.

You’ll need to use a different program or edit the code carbide create spits out. As we’re a competitive product, we don’t expect them to make a onefinity specific post p. The add a hold/pause command in their grbl post p. Just probe before you run any program to set xyz, then run their code.

Do you know what I would need to delete out of the code to remove the hold pause?

the M0 code.

It’s not a bad thing nessisarily, it’s a nice reminder to make sure the router is on, the probe magnet is removed, and everything is prepared before you hit start again.

1 Like

I didn’t realize if I hit play again it would go. Thank you so much for your help. One of these days I will figure out this machine lol

1 Like

Glad it’s going for you!

1 Like

Im having similar issues with fusion 360. When I hit play it starts the cut but the z height is too high and some of the carve doesn’t even get cut. I set feed height to top of model bottom height, i set at -0.125 and like I said half the carve didn’t get cut. Im not sure whats going on.