XYZ probe is setting Z too deep

Edit: My probe measurements are indeed off. The Z thickness is not the same throughout the probe. See my measurements in the pictures.

I posted this on the FB group and still didn’t get any answers.

Whenever I probe XYZ, my Z height is always about 2mm too deep. I always have to flip the probe run a separate Z probe before I load and run my file. I’ve done the fine-tuning that Charley posted on the forum and added the numbers to the settings. I’ve measured the block with two different calipers and got an average of 15mm on the Z height. Please advise y’all…

I’ve never futzed with this as mine looks to be damn close but if it is a consent 2mm too deep why not just lie to the fine-tuning box?

1 Like

If I change the numbers in the settings or lie, it might solve my XYZ probing problem, but it won’t fix when I probe for just Z. I want it to work the right way whenever I probe for either.

3 Likes

About using the probe, I noticed the following.
Probing Z. The end result was too high.
I actually measured the probe, it was 15.2mm instead of the 15.4mm in the settings menu.
I played with this for a while before I realized that I had to PRESS ENTER after entering the new height of 15.2mm, so that the control would register the change.
Just pressing SAVE was not enough.

Yeah, I’ve noticed that too about having to press enter before saving. I still have not figured out my problem yet. I might have to contact the folks at Onefinity directly
to see about getting help, or a new probe.

What software are you using? Where is your origin defined and is there an offset?

The touchprobe thickness should be consistent. When you say it varies are you talking thousandths on an inch?

Yeah, I’m talking thousandths of inches, and I know that’s not a lot, but I have no explanation of why my probe, or the controller software is not working. My software I’m using, if it makes a difference, is Aspire. My origin is always lower left corner, and there is not an offset. My stock is as flat as can be, as I run everything through my drum sander before carving. This is not the first probe I’ve ever used. This is not the first probe that I’ve bought from Charley either. I’m very familiar with the quality and accuracy from previous blocks, that’s why I know something is off.

If you need 0.001” accuracy, maybe you should measure it (0 the Z) manually!!
0 it to the table, and then raise it to whatever height, (note that distance) re 0 it… If you are cutting though, enter that distance as your plunge distance in your software.

But if you are just looking for consistency from the probe, I don’t have a solution for you… sorry :disappointed:
I’m assuming that you’re not cutting wood!!

May be worth a video or some screen shots of all the setup screen in aspire (or provide a gcode example) and the some photos or video of the setup process. Hopefully it is something ‘silly’ but as you said, you have some experience with others so it does seem something is off. A mm is nothing to scoff at.

1 Like

Ok folks, I’ve made a video of my problem:

3 Likes

@charleyntexas can you help me out please?

Well I’ll be damned… That be confusing…

Lol, I’ve been scratching my head for days. This has ruined a couple of my projects until I figured out what was going on. After EVERY XYZ probe, I have to take an extra step and probe Z before I can start cutting. It takes less than 30 seconds to do, but it’s very annoying.

I will test this evening on mine… I have 1.0.6 installed but have only done xyz zero once. Normally only using the probe for z.

Thanks. I’m looking forward to seeing your results.

Is your wasteboard flattened? Try flattening it and retry setting xyz zero. When your doing xyz zero, your probing off the top right corner…but it’s setting those settings for where it returns to after it probes…the bottom left of the probe. When you did z, it’s probing for the exact same spot that you tested after your removed the probe.
I think it’s the unevenness of your wasteboard, especially in the corners around where the screw holding it to the table is pulling things taught.
When flattening your wasteboard, don’t use the probe, just use the paper method, but try to find the ‘highest’ spot on the wasteboard and make that z zero.

1 Like

My wasteboard is flat. I made sure it was flat before I Vcarved the 2-inch grid pattern on it. I even checked it with a level and straight edge. I’ve probed for Z before at the exact location of XY at the corner with the probe right side up and upside down. I only get the problem when I probe XYZ. Are there any other solutions you might have or any videos you want me to record?

You flattened it with a bit in the router?

I can confirm that my machine 1F does exactly the same thing…
I didn’t think much of it last week, I had to adjust the original 15.4 down to 15.2, everything was working nice…
But today I noticed something different…
Mine is not consistent. Sometimes too high, sometimes too low.
Newest firmware 1.0.6

1 Like

lol, yes. I screwed down the waste board first. Then flattened it with a 1 inch surfacing bit.