24W JTech Laser stuck ON

Was running a job last night that I had to pause to verify the cut.
Laser didn’t turn off on pause.
I reset the machine but now the laser does not respond to M3/M5 and is always ON.

Has anybody run into this?
Is there a way to reset the JTech controller?
(I’ve tried the red reset button etc)

Performed the steps outlined here,
Jtech Laser Diagnostics Test - FAQ / Laser - Onefinity CNC Forum

My conclusion is the driver in the laser body itself has gone bad, since I tested the input to the laser and it is correctly(?) adjusting from 0 to 5V when OF controller sends M5 vs M3S1000

Will contact JTech support tomorrow and report back.

Update: Contacted support and they sent a new laser which solved the issue.

I’ve got the same problem. I’ll contact Jtech support tomorrow.

Not sure if you have the same issue but when I set mine up the laser would turn on and I couldn’t adjust the power or turn it off without turning the power switch off.
I must have bumped the mode selector switch when I unpacked it. Jtech exlainded to me if its in manual mode it will immediately turn on at 100% and you can’t control it with gcode in the MDI or with a program which makes total sense.

1 Like