Laser not firing

Hello,

I received my Onefinity and JTech laser a couple of weeks ago. I setup the laser this week and it would not fire with the M3 command, but it would if I flipped the switch on the JTECH controller to turn it on at 100%. After troubleshooting with Onefinity, we concluded it was a bad Onefinity controller. They sent me a new one, which I received today. This one is doing the exact same thing as before.

After plugging everything in, I powered it up, and cancelled out of homing. Then all I changed was reversing the Y motors since my rails are flipped. Then I tried M3 S10 and nothing happened. I went up to M3 S100 with nothing. So I powered off the JTECH controller and unplugged the cable going to the laser connector on the Onefinity controller. I issued an M3 S255 and probed the connector and got 0 volts, just like the first controller which we thought was bad. Then I went back and unchecked dynamic-power and tried again, with the same results. I can’t imagine I got two bad controllers in a row. What am I missing?

Thanks,
Nate

Did you change the “tool” in the Onefinity fly out menu to “pwm spindle” AFTER you swapped controllers?

They were both defaulted to that so I didn’t have to change it.

Hi Nate,

I would try doing the same sequence with the laser driver plugged into the onefinity and then see if it turns on. If it doesn’t, then check the voltage at the H2 terminal. It is easy to get to to check this.

image

You should see 3.3V here if the controller is working and the cable is good. It should also turn on the laser. Make sure you have it plugged into the correct port as well just to double check. Make sure you push it in all the way as I have heard they can get stuck a bit.

Jay

1 Like

I just wanted to follow up on this post and say, again, Onefinity and Jtech customer service is second to none. It turned out that I had accidentally hit the AC button on my multimeter. When I switched that back I was able to measure 3.3V all the way to the laser driver. Jay is sending me a replacement tomorrow. Can’t beat that!