Need a little help with the Jtech laser

Just installed the Jtech laser and running into an issue with the 1F sending commands to it.

The laser fan turns on when reset, the laser will fire manually no problem… but no action when trying to send commands from the 1F controller, manual or GCODE.

I’ve tried M3 S10 and all the way up to S100, I can’t even get the “laser on” LED light to come on.

I believe I have tried everything that I could find here, including Dynamic-Power and raising min-duty. I’m not homing the machine at startup… what am I overlooking??


Having the same issue feeling like I was scammed outta 700$ lol

1 Like

I noticed a recent discussion on the 1F FB page. One person contacted Jtech and after troubleshooting is being sent a new laser. Another had a faulty cable. Have either of you reached out to Jtech or 1F for support yet? I am sure it will get resolved in a timely manner.

Mine is pretty finicky but here is what I normally have to do to get it to fire via the M3 S10 command.

On first turning everything on with no homing of the machine, I can get the laser to fire with M3 S10 to set my zero. I can then run a laser cut file without issue.

After that, I have to hit the screen based e-stop before I can use any manual commands again. I got the screen e-stop, reset the screen e-stop, zero with M3 S10, and I’m good to cut again.

So my suggestion is to try that. Reset the screen e-stop and try immediately to run your M3 S10 command.

I was also able to get the M3 S10 to fire at will with the dynamic power set to off. You just need to remember to turn it back on before you cut or things can go south. I almost started a fire on a project. I don’t do this anymore. I leave dynamic power checked and just do the screen e-stop reset each time.

Onefinity needs to get on a firmware fix for this. We shouldn’t have to jump through hoops to get the laser to work on an officially supported product.

1 Like

as @Storm27m stated, Do not home the machine. For whatever reason it doesn’t like that when entering MDI commands to fire the laser. If it is still not firing, try upping the S part of the command. Mine is around 30. so, M3 S30. To be honest I would start at S10, then go up by 10 until it fires, but doesn’t mark you’re material. When I was having an issue awhile back (my own stupidity, lol) the folks at JTech explained about upping the S part of the MDI command. Hope this might help a little.

1 Like

I reached out to support, we tried a couple things and quickly determined I was not getting the required voltage on H2 in the link below. It ended up being a faulty connector, everything was soldered just fine, but the contacts between connectors were intermittent. I cut the connector off on the cable and used the screw terminals for a solid connection, everything works perfectly!

1F and Jtech support were great, offered to send me a replacement, which I don’t need, I prefer to use the screw terminals for a permanent install anyway.