Confirmation on the Logi F310/F710 Joysticks

Hello Everybody,

I searched pretty much the entire forum for confirmation if either the Logitech F310 or F710 fully work with the Onefinity, only to find mixed answers. I have three F310s and tried them all:

  1. Only X,Y movement worked. No Z, speed settings etc.
  2. Nothing worked.
  3. Nothing worked.

I tried all three of them using this website on my PC and they all returned good values.

Has anybody had any luck with using a Logitech F310/F710? Do they fully work?
Do I need to press any buttons in order to get full functionality?

If anybody has gotten the F310 to work properly, that will save me from buying any additional joysticks.
If not, I would much rather buy the Logitech F710 than the “stock” controller (if it works as intended).

Thanks for your help!

I have the Logitech F310 (940-000110) Gamepad. I have had no issues with it. It controls X Y Z and the speeds. The shoulder buttons lock out the appropriate X or Y. There is a switch marked X and D but I never touched it. I plugged it in and it worked.

I bought the F710 from Amazon and it works perfectly. I’ve had the machine now for about 3 months and never had any issues with this controller. On a side note, I’ve been using Logitech devices for more then 20 years and really don’t have any issues with them at all. Good choice in my simple opinion. :slight_smile:

I have this gamepad from Amazon. It’s $34 unless you’re okay with crazy colors and then you can save $4.

It works perfectly. The dongle goes into the back of the controller (in my case inside a compartment in my tilt-table setup). I press the mode button for a couple of seconds and it turns on in the correct mode. If it shuts itself off due to timing out, the press takes care of waking it up again. All the buttons work as they should. I’ve been using it since November when my JM arrived.

Not sure why other ones don’t work, and maybe I’m just lucky, but for $30 I wouldn’t mess around with other ones that sometimes work or don’t for more than one session before I jumped onto Amazon. In stock with 2 day delivery for Prime. :slight_smile:

Thanks everybody for your help. Much appreciated!

I have a F310 and it works fine. I thought that if it wasn’t working correctly you just needed to change modes.