JTech 24 W Glitching and spotty

I’m new to forums and don’t usually participate, but I am baffled and in need of help.

I have had some second thoughts about the JTech 24W. When I first set it up it would not fire until I got up to M3 S13 and then it would flicker. I noticed it would be consistently on if it was not moving, but when moving on the 1F it would flicker. I increased to S20 and still a flicker. Any think Higher and it leaves a mark, so I stopped at S20.

I then did some test gradient cards. The first two came out just fine, so I thought that the glitching may just be how it worked. Odd, but whatever. I then did a test piece to see the power, speed and number of passes it would take to cut. I make these files so I can just run on the wood type I am using when I need them. The laser did what was expected, but missed some of the labels, then just stopped working when it got to testing the number of passes. I stopped the G-code and turned off the laser controller for about a minute and then tried again. It worked fine. I Thought, meh, maybe a one-off-thing. Nope.

Below is a picture of what I am talking about.

Since it worked after a rest, I thought I would keep going and work on my project some more, coasters for my business. It cut out one just fine, the next one it glitched, and I did the same reset procedure I had prior, then tried again. It glitched sooner this time. I have some time lapses of this happening. To save space on this thread, I have linked the videos here:


I worry that I may end up wasting expensive wood due to this glitch and ti start the engraving again would ruin the work anyway.

On other Issue that I found was that the mounting plate to the Onefinity is different than the JT7w. With the JT7w I could leave the plate on and use my CNC with the Suckit vacuum boot on. When I tried this with the JT24w it was too long and cracked the vacuum boot when the router lowered. I was able to salvage the work piece and had to modify the mounting plate. I haven’t tried it since, but fingers are crossed.

Has anyone else had these issues, or something similar? Can anyone render some advice to a remedy?

Thank you.

Did you use a small screwdriver to turn the Potentiometer up a little higher? It can cause inconsistency if it’s set too low.


Thank you for your suggestion. I just adjusted the potentiometer so that it was not glitching at S1 like I had with the JT7w. I have ran two successful projects so far. Fingers crossed it stays like that.