Mounting the laser controller on the onefinity controller

Just got the Jtech 7 watt laser And I was trying to mount it by following the directions. The video says to use the two screw holes on the ONEFINITY control box. My control box has two screw holes exactly where they should be but they have two hex screws inside of them. I tried turning him lefty Lucy and began a never ending tail of turning a screw that wasn’t going anywhere. The screws turn easily but are not backing out at all.

Just wanted to see if anyone had this issue and what the fix for it is. I know I haven’t stripped them but don’t want to drill or do anything crazy. I provided some pictures.

Mine backed right out, when I loosened them. No issues at all. although I think i may have used these instead of the provided ones IIRC, as the provided were a bit small for the existing holes…

1 Like

Dang, did yours have the little silver washers behind it ?

Also thanks for the feedback.

Got it. I decided to try to cross thread it by Angling the screw. That got it bound up and it backed out. When I got it out there was metal flake and on further inspection I saw the thread of the box is really shallow. Probably screwed in a little deep and wasn’t catching the threads.

I really appreciate the feedback ! Would of tried something crazy if I didn’t see it. (Gotta put away the drill and tap set)



Sorry just checking back in. Yes, mine had the extra lock washers, and I used them when reattaching.


Ended up getting it out, threads were not gripping so I tried cross threading it and it actually gripped and came out. Any chance you use vectrics and know which option to pick when downloading the laser module ? It lists a bunch of machine options but none of them are onefinity.

Thanks for all the help, Happy Holidays.


Try this link, several items down the list are the Onefinity versions V2 if you look at the file names.