Pocket toolpath started to leave uneven steps

When I get close the end of my pocketing toolpath, something is making the tool step or raise or something. Did several pockets with no problem, now won’t leave smooth bottom. 3"~ round pocket .75" deep. When it gets close to finishing…it leaves steps toward the outer edge of the bottom of the pocket. I have done multiple projects no problem…now this.

Any chance the bit has moved in the collet? A quick test would be to put the spindle back at Z-zero and see if the bit still just touches the zero point (top of material, or waste-board).

1 Like

I started to see something similar. Tried lots to figure it out without success. One day I noticed the screws on the z-gantry had come a little loose. After tightening, the problem went away.

1 Like

Thanks for the info. Will check tomorrow.

No go on anything being loose. Also checked the tool offset and Zed, no issues. It is actually worse. Now leaving uneven bottom even before getting to outer edge. I said I was going 3/4" deep, actually my material is 3/4…I am going 1/4 deep with a 1/4" ball mill. Making round coaster. Made several with no issues. Even when I reload programs that worked fine, still messed up.




a & b are the current issues. c is when it was working.

That’s very odd.

It looks to me like the Z is not holding during the cut. If the bit was slipping, or the Z-stepper was losing steps, or something else was moving, when you’re done with the cut the 1F should be unable to go back to a Z-zero accurately. Is that happening? Can you go back to Z-zero after the cut is finished, and see any difference from where it ended up at the end of the cut vs. where it started?

1 Like

…and if there is an issue with holding Z-zero, then checking the colette may help; clean, damaged, correct one for the bit (metric and imperial don’t get me started )…

It actually does not appear to be a Z issue. When watching it, it appears to step over to far. Not lifting in the Z. I got a bad feeling about the controller…not good…in the middle of a nice order for a store for Thanksgiving.

Hey Mike,

may I ask, how is the workpiece clamped?

Any changes at all in the CAM? (max stay down…) does the gcode look odd at the point of issues arising?
@Aiph5u raising a good point on stock hold down - any changes there?

Otherwise very spooky - and Haloween has been and gone!

Pieces were held with 2 sided tape. Then switched to being screwed down. No difference with that. At least not what I see. My main concern is how concentric all the steps are. And also how varied they are. Hugely frustrating when I made 20+ pieces with multiple designs an no issues until now. At this point, other aspects of the projects appear to be working. I opened a brand new file and mad just a simple pocket similar to what I am using for the projects and still have the issue. I said it does not appear to be the Z, looks like wrong step-over, but I’m not sure…just an observation. Can’t really tell. To me it seems more CAD related than physical with collet or hold-down…etc…

Hey Mike, hey Mike, hey Andy,

next thing I would ask is

(can’t upload image showing Z-Slider with router removed and magenta arrows pointing at Ball Screw Coupler and at Ball Nut Set Screws)

1 Like

Everything appears tight and good.

I give up :sleepy:. All I have left are spells; stand on one leg, hold a feather in the right hand and say “Izzy whizzy, let’s get busy”

A knackered endmill?

Hey Mike,

You really checked all these?

Onefinity__Z-Slider__Ball_Screw_Coupler__and__Ball_Nut

Powered controller off, removed router, and tried to move Z up and down by hand?

And then no play, no noises?

1 Like

100%
When I switched to an endmill from the ballmill I was using, no steps. Flat. Don’t see anything obviosly wrong with the ballmill. Maybe still stepping over, but the cutting surface of the endmill covering it up???

1 Like

Before I forget…thanks everyone for your help to this point. No help from 1F to this point.

1 Like

The 1F has had troubles with small circles in the past - what software are you using? I’m also assuming you’re on latest/greatest firmware as well.

In Fusion360 some have modified tolerance values on arcs so as to not overload the controller with a bazillion small straight-line steps to make an arc.