4th axis option

Replacing the x or y axis will allow you to use a 4th axis rotary, as long as you don’t need to control the radius. I would like to use the 1F to 3D carve table legs and other items that would require the controller or some sort of add on card to do the step vs diameter calculation as BJ suggested. When I originally bought my unit, it was mentioned as something they were working on, but Onefinity hasn’t commented since.

Roger would it work instead of using the m1 for a axis to use the m0 the x axis as the A? just thinking

Yeah as long as you change everything to the X axis instead of Y

Mr. Roger,
Here we go sir,
I change the settings per instructed in rotary setup for onefinity,
Rotary attachment responds to nothing when the axis is changed to A, but when I change the travel-per-rev and the step-angle but don’t change the axis to A, but leave it at Y now it responds, 360mm turns 1 complete rotation

I am wondering if the updated firmware changed the a possibilities or if there is something I am missing,

Please advise sir,

How are you checking for movement of the rotary when it’s the A axis? You can either enter gcode saying to move the a axis or you can use the joystick but you can’t move it with the arrow keys on the home screen of the controller if you are trying that way. @GregoryG

I’ve not tried gcode but I’ve tried the joy stick
Tomorrow I’ll record it so you can take a look I’d you will

Roger hoping you would share your onefinity-20210706.json file in other words the file that restores back to normal usage, just want to check if I messed something up, sir I thank you and will pass it forward…

I’m not at home but you can just reset back to the original configuration by going under Admin-Configuration-Reset.

I reset as advised, still the same issue, with all the 3 changes

"Change the axis from Y to A. Change your “travel-per-rev” to 360. This will have to be the case for all rotaries for our controller as it is. Change the “step-angle” to whatever is mentioned for your rotary, mine was stated to be 0.3 degrees. "

to the M1 motor , it will not move by any method, however with the changes made except leaving it assigned to Y it moves by gcode, controller, and touch screen, so I figured to give it a try I designed in vcarve and Lightburn five 1by1 inch squares, to see how close it is, ran this test on 2 different size cylinders, they measured correct using Lightburn on both cylinders, however the vcarve pro test measured exact 1 in on the X but .36 in on the Y of course on the pp you sent I changed all A to Y in gcode…I am hoping to use VCarve Pro to Laser fill vcarve on cylinders… I pray we can find some light here, ty

Ok when you set it to A, and you are trying to make it move what are you doing? What gcode in the MDI panel do you use? When you try with the gamepad controller what are you doing with it to try and make it move?

I just resoldered a connection to my rotary to hook back up to my Onefinity from my CO2 laser and it is working just fine. So it’s not a firmware problem. If you want you can email me at rogwhs09@gmail.com so I can see your messages faster than on here.