Bit change my plunge update + video

Hey Everyone,

In my previous post I have pointed my onefinity would give me qurks like plunging into the probe during a m6 tool change. This happen to me at least 5-6 times, I would say its quite frequent so I have capture it in video to see if anyone or onefinity can give me some pointer. Note* this only happen during M6 gcode tool change, if I use probe Z it doesn’t happen or at least I haven’t experience it happen

Another quirk I notice is sometime during my “probe xyz” sequence, the connection between the probe and bit is delay, say 1 / 5. The probe would push the probe 1-2mm before it will detect a connection. This is different then my M6 tool change plunge issue which is a bigger problem on my hand.

Should I replace my probe? or something wrong with the firmware? I am baffle, if someone please shed some light that be great.


That is bizarre, I use M6 tool changes very frequently and have not seen this issue. One thing I notice is the probe cycle is traveling a long Z distance before it makes contact with the probe, I tried this on mine several times with no issue but not something I typically do.

The other thing I notice in the video is it seems the M6 is running near the beginning of a file which shows the Z axis tool path as under - this may be throwing things off a bit. Perhaps try probing XYZ before running the file.

Can you post the first 20 lines of the file you’re running in the video?

Hello Derek,

I have probe xyz after homing the machine before starting the job. In the video M6 tool change happen within the file after the first tool oeration. The cam was program in fusion360.

This is giving me anxiety every time because I wouldn’t know when it will happen. If I am not cutting foam my bit will be done. So I couldn’t move to any harder material unless i get this resolve, or forgo using 1 file with multiple M6 tool change and switch to seperate file which will be slightly more truoblesome.

First 20 line

(T1 D=0.25 CR=0 - ZMIN=-1.52 - FLAT END MILL)
(T15 D=0.125 CR=0 - ZMIN=-1.04 - FLAT END MILL)
N10 G90 G94 G17 G91.1
N15 G20
N20 G53 G0 Z0

N25 S18000 M3
N30 G54
N35 G0 X6.4728 Y4.7995
N40 G43 Z0.6 H15
N45 G0 Z0.2
N50 Z-0.475
N55 G1 Z-0.4875 F110
N60 X6.4727 Y4.7992 Z-0.4903
N65 X6.4723 Y4.7984 Z-0.4929
N70 X6.4717 Y4.797 Z-0.4953


at 8000 line M6 tool change

N40330 T1 M6
N40335 S18000 M3
N40340 G54
N40345 G0 X10.3775 Y4.0004
N40350 G43 Z0.6 H1

That all looks fine to me. The only other thing I can see is you’re generating the file using imperial units however the controller is using metric units in the video - perhaps try changing the units in Fusion 360 to MM in your manufacture setup and re-generate the file that gave you trouble before. I run all my manufacturing setups in metric and haven’t experienced an issue. I’d also just verify the code on the settings page for the M6 tool change looks something like this:

(Runs on M6, tool change)
M0 M6 (MSG, Change tool and attach probe)
(probe to minimum z soft limit, which is -10)
G38.2 Z-10
G92 Z15.45
g0 Z30
M0 (MSG, Remove probe, start spindle)

One thing I’ll mention too - if I run a file that with the Z axis “under” that starts with the M6 command (in this case I used the team onefinity.ngc as it starts with the M6 command) the Z axis will only probe for 10mm before it e-stops the machine. In your video it is traveling a much further distance so I’m guessing you’ve changed the G38.2 Z-10 command to something larger. Not sure if any of this is causing the issue but stuff to look at and try to rule out.

Hi Derek,

Thanks for the prompt reply.

  1. I will definitely rerun generate my gcode in metric to see that solve the problem.

“(in this case I used the team onefinity.ngc as it starts with the M6 command)”
Do you mean post processor? can you clarify? I am still learning :slight_smile:

My spindle automatically go to a very high z position during m6 tool change. Is that something I can tweak to make it lower? For me, when I switch to a very long bit like 2.25 " stick out. I haven’t change any code inside onefinity setting for m6 tool change. I believe it is still G38.2 Z-10 .


Sorry I didn’t mean to confuse things - I didn’t have any files that had a M6 near the top so I used the “team onefinity.ngc” which was the file that came loaded on the controller when it was shipped. It has a M6 tool change command at the beginning I used to test probing when the tool path was “under”

Can you post what you have in your controller settings for the M6 tool change command?

absolutely, the cnc is at my friends garage, I will grab that information and posted here tonight.

Tool change command in controller setting

(Runs on M6 Tool change)
M0 M6 (MSG, Chane tool and attach)
(probe to minimum z soft limit which is -10)
G38.2 Z-10
G92 Z15.4
g0 Z30
M0 (MEG, Remove probe start spindle)

Mine is the same as the one you posted , i just checked

Your second M0 line has “MEG” instead of “MSG” - I tested mine with your M6 code and with that MEG typo I couldn’t reproduce your results. I’m stumped.

I would test changing your units to metric in the manufacture workspace in Fusion 360 and test that.

sorry i hand type that, it’s MSG.

yes i am going to give that a try. thanks for your suggestion