Final cut is off (solved, user error)

Anybody else have this issue? I’m cutting out a project. The first and second cuts are great but when I switch to the third bit to finish cutting out the project it is off from the rest of the projects by a couple inches completely ruining the project. When I zero the machine it is a soft zero and that is the only time I zero the x and y. I zero the z after every bit change. I have the onefinity woodworker

I have just run a few jobs with 4 bit changes and no issues to report.

What CAM are you using? Could be differing offsets for the tool paths, a “rogue” tool path from creating the toolpaths.(a previous creation not cleared), multiple work centres…

I MAY be having the same issue … I’m not certain, and I MAY have a work around. I recently did a two tool (and two tool path) engraving where I probed for XYZ using a 90 degree Vbit (and using the Onefinity probe). When asked by the cnc software for its cutting diameter (during the probing dialog) I inputed .5" (which I believe is correct for THAT bit). I used two tool paths, one with a 1/16" end mill, the second with the 90 degree vbit. I switched bits (to the 1/16" end mill) before starting to cut the first tool path and re-probed for Z only. At this point the software does not ask you for the bit’s diameter, so I assume it is still using .5" inputted for the 90 degree vbit. I cut the 1/16" end mill tool path first. I then switched bits to the 90 degree vbit. Upon cutting the second tool path (the 90 degree bit path), I found the cutting (of the 90 degree bit tool path) to be off by 1/4" to 1/2". The solution so far has been to do the initial XYZ probing with the 1/16" end mill (responding to the software that it’s diameter is .0625"), cutting the 1/16" end mill tool path first, then switching to the wider bit (the 90 degree vbit), and cutting that tool path secondly. If this IS the issue I’d think the onefinity software needs an update. If this winds up to be/fix your issue, please take a moment to update your posting. It will help me with my troubleshooting.

I highly recommend setting the stock XY origin in the same location for all toolpaths and only varying Z as necessary. That way you set your XY location only once before you cut your first chip and only have to update the Z when you change tools.

This is still not foolproof though. Reference my post from a couple of days ago…

1 Like

Garyn - recommend you don’t use anything other than a straight bit for probing XY.

The XYZ probing procedure asks for the diameter of the bit so that it can calculate the bit’s XY center BUT it probes along the first 1/4 or so of the bit’s length. For a straight bit - constant diameter along its length - this doesn’t matter. But a 1/2" vee bit is NOT constant diameter and in particular is NOT 1/2" diameter where the bit first contacts the probe. So your zero is off.

You will have the same problem with any bit that is not a constant diameter along its length.


1 Like

wotring80 - for troubleshooting, do your toolpaths all look correct relative to each other under simulation?

Ideally, look at your gcode files in a gcode viewer and look for the same issue - since what you are simulating might not be the same as the gcode you are running.


Thank you everyone. I am using Fusion 360. It was all user error, I originally built the tool paths then a couple days later moved everything over a bit in the program. I spaced it and did not clear out my final cutout nc code