G code too large

I’m a newbie.
I ran a program load my proyect and tool pahts and that the program creates a gcode are to large ( 42.9 MB) and will not run in the onefinity controller. i dont have problems whit small files, Do anyone know how to run this large files. any sugestion
thank you

When you say won’t run do you mean it errors or that it just sits at the processing screen? I don’t think the file is to large but it will take a while to process…

sits at the processing screen and the botton of the where show up the gcode said File is large - gcode disabled.
thank you

I have manually split them and added in the gcode to start/stop the spindle which works.

I’ve seen references to this utility but I have not personally used it:


I believe it says file is large… Gcode preview is disabled… You can still run the file but it won’t try to preview on remote devices via the browser.

dont let me run it becuse the screen is frozen, i how to reastar the the controller what you mean preview is disable
thank you

I know it sounds ridiculous but have you let it sit overnight?

today after bean sit for 20 minutes got load it
thank you

1 Like