MDI - more than one line of Gcode at a time?

Using the Manual Data Input (MDI) function of the controller control screen, can you input more than one line of G Code and then run it?

I have tried to enter a few lines of G-code and it appears that you can enter only one line at a time and hit run.

If you can enter more than one line at a time, what is the syntax for separating the lines in the input screen? I have tried all sorts of things from semicolons to Alt Return to . . . . . .

The answer is that it only executes one line at a time. Enter the G-code in the MDI input window and press the play icon; then enter the next line of code and so on as you step it through.

Be sure and hit the stop icon in the MDI section when you are finished. Otherwise you can induce errors into the controller that will show up in homing, etc. Ask me how I know!

Yes, I had to reset to the controller defaults to get my scrambling of the eggs to clear.

Hey Alan,

me I would instinctively have tried “\n” :slight_smile:

Anyway the Documentation is silent about this

The support person at 1F that I talked said it only takes one line at a time. Naturally I would like more! I will try your suggestion.

I did look at the Buildbotics website and didn’t find the answer. I have also wondered if the Buildbotics documentation is totally applicable to the 1F controller?? I understand, again from support, that the 1F firmware is “forked” from Buildbotics and that they are not the same.

Most of it would apply since we’ve forked from their firmware, but not all.

1 Like

Can you confirm that the MDI accepts only one line of G-code at a time?

It’s pretty easy to just make a small gcode file with the commands you want to run, and just run it like any other carve. I made a “warmup.nc” file for warming up my spindle, 11 lines of g-code:

S8000 M3
G04 P60.
S12000
G04 P60.
S16000
G04 P60.
S20000
G04 P60.
S24000
G04 P60.
M5

If you’re handy at a Unix shell prompt (and have a keyboard handy) - you can escape into a shell and use vi to create the file right on the 1F…

4 Likes

Thanks Mike,
Agreed but I am trying to run just a few lines via the Manual Data Input (MDI) screen.

I understand what you’re trying to do - but the OneFinity UI just doesn’t allow that.

Okay. Looks like you have been down this road too.

Thanks for the warmup code example.

1 Like

I was wondering if anyone had done this.