My file won't run cause its paused?

I’m pretty new at cnc and I want to do more with my machine than Easel will allow me. So I’m graduating to Carbide Create. I downloaded one of their files and loaded it into my Onefinity and when I started to run it I got a " paused " response on my control screen. I thought it might be the file itself so I tried another file from Carbide Create tried to run it and got the same response, a flashing yellow box saying " Paused ". I don’t know whether its My Onefinity or a Carbide Create issue.
If anyone has any idea or experience with this problem please let me know. Im going to go to the Carbide forum and ask them the same questions.

Hey Philip,

this is this issue. Carbide Create creates g-code which instead of M6 (tool change) commands contains M0 (Pause) commands everytime a tool is selected, followed by a comment that includes the tool number (that is ignored since it’s commented out). This is because with Carbide Create, the M6 command is only implemented if you hand your g-code over to Carbide Motion software which exclusively runs on Carbide CNC machines.

You can get rid of this by replacing every instance of

M0 ;Txxx


M6 Txxx

in your g-code file.

Note that if you use M6 commands (multiple tools in one g-code file), take a look to check if the settings in the ‘tool-change’ field of the General Configuration Tab of the Onefinity Controller suit your needs. Regarding what to insert there, I cited some information here the other day.

1 Like