Need configuration saving help

Hi folks!
I’ve had my X-35 for 3 years and have done software and hardware upgrades with no problems, but this one has me scratching my head.
Running 1.3.0-alphaa4 on the BB
*I installed the HD Z-20 and went to do the configuration setup. As always, I do a config backup first, but this time it’s not backing up right. Instead of the normal JSON file (like onefinity-20230614,JSON), all I get is Unconfirmed 372180.crdownload
*On top of that, after I did do the reset (I have backups anyway or can re-install) I chose the X-35 & Z20 and saved it, then all the Z would do is go to the top and make noise. Thanks to the forum, I solved that by reducing the stall voltage to .8
*BUT now my X & Y only traverse half way.

Should I do a re-install of the BB software? Should I flash the card?
Or am I missing something?

I would check your max soft limit and travel per revolution values for the X and Y, if it’s the original woodworker they should both be set to 816mm for max soft limit and 10mm for travel per revolution. The Journeyman X axis is 1219mm max soft limit and 16mm travel per revolution

Why are you running alpha when final is out and even one version past?

Because it was running perfectly on Alpha. Actually I didn’t realize that there is a new version. I guess I should update.

Updated to 1.3.1
Reset config
Set machine to X-35 Woodworker & Z-20
Z stall still not stopping
After setting Motor 3 stall voltage to .5, then everything worked perfect.
I now have full carriage movement
But I still cannot save the config file. Still getting Unconfirmed 372180.crdownload (different number everytime) which vanishes when the computer is rebooted (tmp file I gather?)

.crdownload (short for chrome download) is a download file in progress that doesn’t seem to be completing for some reason - perhaps try a different browser or incognito window (might be an extension blocking it).

1 Like

This is interesting.
Before the update to 1.3.1, I had no problem saving config files. Even in 1.3.0 Alpha I had no problem.
But now I cannot save the config files in Chrome, not in a regular window, an incognito window, or even after the cache is cleared completely. I can only get the temp file (crdownload)
I hate hate hate Edge, but I can save the config from it.
I have switched over to Firefox which I use to use years ago, and I have no problem saving the config file from it.
Chrome was getting too bloated anyway…
Thanks for all the help,

1 Like

I just tried setting my numbers to the figures you gave for the original Woodworker and my travel slowed down to a crawl (all numbers are in mm)

max soft limit = 816
travel per revolution = 10

After double checking that I had set the right figures and locations (which I had), I then reset them to what they were and it ran fine (this is the 1.3.1 settings)

max soft limit = 32.126
travel per revolution = .3937

I then looked up the figures from my old 1.3.0 config file and they were:

max soft limit = 0
travel per revolution = 10

Why the big difference? Any ideas?
It seems to be running perfect now, but I haven’t cut anything yet.

You can always reset back to defaults here:

This is what I did after installing the Z-20, yet the numbers are now different than they were before 1.3.0 (I must not have saved a config file after the 1.3.0 upgrade) but everything works perfectly. The Z I understand, but I would have thought that X & Y would have stayed the same. Attached are config files from 1.3.0 & 1.3.1. Note that I always add labels to my saved config files.
I’m not worried about it as it seems to be working fine, but thought you might like to see the files.

onefinity-20230614 - before upgrade to 1.3.0 RC1.json (12.8 KB)

onefinity-20231230 - 2after upgrade to 1.3.1 and custom Z block size and speed & Z voltage.json (12.8 KB)