Please Help with Huanyang to Onefinity Controller

I have hooked up my breakout board to my Huanyag VFD as per all videos and literature. I even watched the Build Botics video and read their instructions on how to do it. Running a g-code the rpm goes to 24,000 rpm no matter what speed is set in the tool path. I can reset all of the onefinity controller and VFD to back to normal and the VFD and spindle works correctly through the VFD speed dial (pot). The actual G-code shows the correct spindle rpm. but the onefinity runs the spindle to the max rpm. 24000. What am I missing or is the Onefinity sending the wrong info to the VFD. I have updated to the Beta update that is now out.
Please help!

There may be some information in this post which might help you out.

1 Like

Did you set the min and max RPM in the “Tool Configuration?” You should change the max to 24000. By default I believe it’s set to 255. This means that when you set your spindle speed to anything over “S255” your spindle will run at full speed. You can test it by setting your spindle speed to “S127” and see if it runs at 12000 RPM.

1 Like