Z problem with first time homing not zeroing (solved)

Hello, my machine homes to the front left and X Y and Z are all green, however on the screen the Y & X are at 0 mm, but the Z is at 133mm. If I use the zero icon to bring it to zero the absolute stays at the 133mm. If I go into the motor configuration and change the max soft limit ( which reads 130mm) to zero I get a warning pop up. I’m not zeroing, just homing, and I believe 133mm is the length of travel for the Z drive. I have not updated the firmware yet, but don’t think it would have anything to do with this. Has anyone else ran into this? Any help would be appreciated.

1 Like

There is no issue. Do not change default values. Go through with the rest of the steps to carve.

Okay thanks! Thanks for the quick response. I was just worried as a first timer, that something was wrong.
Thanks again…

I still have the same issue! Z does not home to zero. I have used the probe to see if it would zero out after the probe, but everything is still the same. The machine won’t home to zero? it’s the first thing the machine needs to do before moving on. I can’t find anyone else that has this issue on the web. Is there resolve for this issue? has anyone else ran into this? I’ve had the machine for a couple months and can’t use it, so sorry for my frustration. Any ideas would be welcome.

Hey bobaluke,

Why does Z not home at Z’s lowest value?

You just have to think about it. When homing, the machine does not know about your bit length, so if it would home at Z’s lowest value, you would have a broken bit or a hole in the table.

What the machine needs to know at startup, is where are the axes positioned. Since with open-loop steppers and with the machine lacking limit sensors, it cannot sense it, so what the Onefinity CNC does is to drive the X and Y axes to front and left until it can’t go further (the stepper drivers have “stall detect” capability) so it sets machine origin (aka “home”) to zero for X and Y when these axes reached there, at the front and left ends of their travel.

Since as explained, it cannot do the same for Z, which means it cannot drive the Z axis to its lowest position without risking to destroy something, it simply drives the Z axis in the other direction, which means upwards, away from low position values towards higher position values, until the motor triggers a stall detect at the highest point too.

Now the stored machine’s soft limits come into play, which are stored under Flyout menu → MOTORS → Motor $ → Limits. For Z axis, it is found under Motor 3 → Limits. As you can see, the “min-soft-limit” for the motor 3, which is the motor for Z axis, is set to a negative value: −133 mm (in imperial, this is −5¼″). Hey, this happens to be Onefinity’s maximum Z travel distance, did you recognize it? :wink: What this means is, by reaching the other end of the Z travel, and then subtracting the maximum possible travel, the machine knows where machine’s Z lowest position is. And that’s what homing is all about! :wink:

Schematic Representation of a CNC vertical milling center
– Source: Smid, Peter: CNC Programming Handbook , Industrial Press, South Norwalk, CT, USA, ISBN 9780831133474

By the way, many industrial vertical milling centers don’t have their X and Y home point at the lowest value either, but at right rear ends of X and Y travel (which is then also where the tool magazine for automatic tool change is located). The way to know where the axis’s lowest value is works the same way internally as explained for Z above, by looking up the stored limits, which then would also be negative values (unlike the X and Y lowest values on Onefinity). Manufacturers can decide that differently. Machine origin (aka “home”) is just a reference position the machine has to take once at startup with the homing command.

As soon as you have loaded a g-code program, usually you have a new coordinate system in effect, with a program zero (or workpiece origin) that defines where X zero, Y zero and Z zero are and that the machine gets to know in relation to machine coordinates by probing axes or moving and zeroing axes manually.


All Machines Specs

1 Like

PS: Note that for the Onefinity Machinist, Woodworker X-35 & X-50 and Journeyman models with the classic “Z-16” Z assembly, in the Motor 3 Limits settings, ‘min-soft-limit’ has to be set to “-133” and ‘max-soft-limit’ has to be set to “0”. If you changed settings and are not sure what are the correct defaults, you can reset to defaults for your model on the ADMIN page. I assume you have firmware 1.0.9.

Thank you very much for your response! My machine is finally homing to zero. I really appreciate your help!

Thanks again!!

1 Like