A new z wrinkle

Hi you guys a little help on this please if you can. I have been carving and groovin and having a great time. I came out to do a project tonight and no matter what I do in settings I cannot get z to touchdown. I’m air carving a hair above the wood. I do all my work in easel and download to my computer then upload to the machine. I have some pretty big projects coming my way and this wrinkle has me a bit worried. Any help would be oh so appreciated.


What method are you using to zero the workpiece (touch-probe, paper). Also have you accurately measured the thickness of your material. Are you sure you set a depth of cut in Easel?

Also have you surfaced your wasteboard? It is critical when you are doing high detail low DOC vcarves that your surface is 100% flat and perpendicular to the router. Otherwise, you will get that air carve you mentioned in areas that are even a few slightly thinner.


1 Like

I was having this issue over the weekend but with VCarve, not Easel, so this probably isn’t your issue but you can check. I’m still not even sure why this was an issue. Long story short, check your post processor.

When I initially set up VCarve with the Onefinity post processor, the output was a .ngc file. I went out to start some files on Friday night and when I went to save the Gcode file, the software made me pick the post processor again (it was blank, when it is normally already populated). Without thinking about it, I selected one of the two options availabe (Onefinity Inches or Onefinity mm), saved my files, and transferred them to the controller.

Every single file that I uploaded that day was just cutting air no matter what I did. The files that were already in the controller worked fine. After about an hour of frustration (checked machine, toolpaths, zero, re-homed, basically did everything I could think of), I noticed that the post processor in VCarve had changed from outputting a .ngc file to outputting a .gcode file. The post processor for outputting a .ngc file was no longer available. After resetting the computer and the software, the .ngc post processor was back. I saved and transferred my files and they ran without any issues.

The issue that night was that VCarve had somehow switched to a .gcode post processor instead of .ngc and the file was running everything except the Z-axis. After I switched back to the .ngc post processor, everything worked fine. I found it odd because I’ve run .gcode files from another software (JointCam) just fine. The only thing I can think of is that the .gcode file from VCarve was tossing something in there that the Onefinity controller didn’t like. I was in a hurry to get cutting so once my files were running, I just got to it and didn’t stop to compare the code from both files.

Different software for you but it might still be worth looking into.


thanks @Storm27m You gave me a few things to think about that I hadn’t thought of so I’ll check it out, I appreciate your help!

Thank you @MindOfMcClure I appreciate it, I’m pretty darn sure it’s right but will check again. for sure.

Hi @pootaholic I am using paper method, it’s one I’ve used before and has always worked.

So many variables here.

If it was me, I would put the gcode into CAMotics and verify that everything simulates and looks as I expect (Z heights, movement, speed, etc).

If everything on the gcode side looks exactly as expected, then you can move on troubleshooting the machine itself.

1 Like