Anyone know how to set Time & Date on Controller?

Is there a way to set the time and date without connecting to WiFi?


I haven’t been able to get wifi working yet so I’m in the same boat but am still hoping someone can shed some light. I see nothing in the fly menu for it.

I am having the same issue and my machine is connected to WiFi. My current project is 1:53:48 long and its got 10 min to finish, the current time is 5:51PM CST and my ETA time on the carve is 23:00:59 clearly there is a wrong time setting somewhere?

Any advice??

Look at this

1 Like


I thought OneFinity told the users not to upgrade the Pi OS???

In looking at your code string, you are suggesting “sudo apt-get update / upgrade” which will do just that. Have you tried this on your machine? Just wondering if maybe in one of the new Firmwares if they enabled the ability to safely upgrade the OS or if you just gave it a whirl and it worked.

Thanks for the workaround!


I always use a new sd card and flash it with last firmware before doing my test. To answer your question, yes I did it on my 1F. I noticed that the upgrade problem was related to hostapd and that’s why it’s mark hold in that code.

1 Like

Awesome thank you great to have a linux pro in our mix!