Aw Snap, something went wrong

Does feel like a standard IT response along with “switch it off and back on again” :grin:

Hey Ben,

Are you sure that when this error is present, that you can still get the application over phone/computer? In the same moment?

Hey Ben,

you could try the following:

Open a shell, and do

sudo editor /etc/chromium-browser/default

and replace the line

CHROMIUM_FLAGS=""

by the line

CHROMIUM_FLAGS="–disable-features=RendererCodeIntegrity"

EDIT: Just checked what the chromium-browser’s version inside Onefinity 1.0.9 image is: Still 60.0.3112.89, very very old. So unlikely that it’s the “RendererCodeIntegrity” issue which was added to chrome 78, that could be this “Aw, snap!” cause.

So it’s another “Aw, snap!” cause. Chromium-browser had many different “Aw, snap!” causes in the past.

Deleting this post until I know a better chromium-browser option to insert.

Hi Aiph5u,

Yes, the only way I can do a proper shut down on the controller when the error is present is through my Computer or phone browser. Since I cant get to the fly out menu on the controller.

I have had the machine on all day today and the error has not occurred, I really don’t understand it

Hey Ben,

I would think it seems to be one of the many issues chromium-browser shows (over time, in many versions)

As long the application runs, it is fine to use it over the Network. We didn’t even order a Touchscreen with the machine, mainly because with 7" of 10" display size people over 45 years would need glasses (presbyopia).

You should be able to hit refresh on the onefinity screen

@Hermsen.BJ
I have done that hundreds of times. It refreshes right back to the error page. Maybe once in 10 refreshes, it shows me the onefinity interface page for a half a second and then the Aw snap page comes back.

I have closed the browser completely, it reloads automagically and instantly goes back to the error screen.

This has to be a display error yes? If it was the controller I wouldnt be able to get to it on other devices, I think anyways.

I originally ordered the 10" display, When my machine was about to ship the 10" displays became back ordered and they had sourced a new smaller display in place of the others they sold. Im concerned this new small display may be the issue. I don’t think there’s a ton of them out in the world yet with the onefinitys.

Hey Ben,

It is an error of chromium-browser, the web browser installed inside the Onefinity Controller and in which you use the CNC Application when working directly on the Controller with a HDMI Monitor. When you use the CNC Application over the network, then you use another web browser so error doesn’t show up.

1 Like

I wonder if I can install a different browser onto the display? Has anyone done anything like that before?

Hey Ben,

you don’t install it onto the display, but onto the computer inside the Onefinity Controller. The operating system of the Onefinity Controller is Raspberry Pi OS (formerly Raspbian because it is based on Debian GNU/Linux) so of course you can log in as root and update the system (and thus, the chromium-browser package) or install other packages, but be aware that this is for advanced users only and you need the knowledge to administrate a unixoid operating system and at same time know the Raspberry Pi. Also the system as it is relies on using chromium as the browser. In any case if you want to modify something here, Onefinity Support will surely tell you that they don’t support this.

If you install and use another browser, you got to make sure it is started after X autologin and that it is configured in a way to show and let use the CNC application correctly. Rather than use another browser, I would upgrade the ‘chromium-browser’ version. As the version of Raspbian on 1.0.9 Onefinity Image is old (9.3 “Stretch” from 2017), you got to make sure /etc/apt/sources.list and /etc/apt/sources.list.d rely on the correct (old) release and you got to prevent that Raspbian is upgraded to the newest version because you can not be sure everything will upgrade or keep running without the multiple interventions of an experienced Linux, Debian, Raspbian administrator, and it would be good to be experienced with bbctrl internals too.

2 Likes

Sounds like something got corrupted.

Hey BJ,

it is true that when Ben says the error didn’t show up all day today and then suddenly it appears, that there must be an underlying cause, which triggers the error in the browser.

Of course a fault in the SD card could have appeared but it would be probable that there would appear more errors then too, what do you think? I had a SD card failing the other day but then the system produced very much different errors. Normally nothing gets corrupted in a working system with so little user intervention options.

If it happened to me I would look at all log files. But for a normal user, reflashing would be worth a try. But you got to backup and restore your settings.

Totally agree. Flashing is probably an easier thing than digging to deep but may also not fix it

1 Like

Thanks for all the help here. I am surprised no one else has chimed in with the same issue. I am not a complete novice when it comes to re-flashing firmware so I may work on that this weekend. If i discover anything new I will post an update.

Thanks again everyone

1 Like

I am having the same “aw, snap” issue!

Unfortunately I haven’t discovered a way to stop it. I have been lucky for the last 2 weeks and not had the issue but the machine hasn’t been powered on for long either. I will post again if I discover anything new

This is still a CONSTANT issue for me, has anyone figured out why this might be happening? I am currently on my 4th restart because it goes to the Aw snap page within minutes of being powered on. Im getting incredibly frustrated.

In a fit of rage I started unplugging things from the box, and believe it or not when I unplugged the USB camera and hit reload, it actually worked.

I have never once been able to reload and have it successfully reload itself. It must be the camera causing it to crash, are there plugins or anything I can get that might help with this?

Some USB webcams can affect the box (especially 1080p ones as they send 4x the data as the recommended 720p camera)

1 Like

Thanks for the response. Do you have a webcam recommendation? I apologize if its listed somewhere and I missed it