Onefinity screen froze on start up

Hi Guys,

I shut down my machine for about five minutes via the proper shut down menu option. I flicked off the rocker switch and the monitor.

When I tried to start it up again, the screen is froze on the same graphic that it shuts down with (half onefinity logo and a bunch of black text).

I don’t want to manually hit the kill switch unless I have to. Any suggestions?

Also wondering if the red light stays on inside the control box even when everything is powered off. I noticed it when I shut my shop lights off the other night after shutting down.



It may not have fully shut down if you still had power applied to the display it can back feed through the USB cable to the controller - try also unplugging the display.


I’ll give that a shot in the future. As for the frozen screen on start up, any ideas? I finally decided to use the rocker switch to turn off the controller. I haven’t tried to turn it back on again yet.

The frozen screen may be the result of it never actually powering off due to the back feed of power from the display, when you disconnect the display it may correct itself.

1 Like

This is exactly what it is. The screen either doesn’t get turned off when the controller is turned off or it is turned off and still back feeds it’s power to the pi inside the controller and gives it just a low enough voltage to stay ‘on’ but not enough to use the machine.

Either turn off the screen when shutting down or remove the usb c cable that provides touch from the controller to the screen.

Ok, I will go give that a try right now. I just tried to turn it back on earlier this morning and the same screen was showing as when I shut it down last night.

Fingers crossed that this works!

So I tried what you said. We have some progress but still an issue.

I was able to get the controller shut down once I unplugged the usb c touch cable. When I started up the controller again, I was able to move the machine with my game controller, but when I powered on the monitor, I get a no signal message.

I tried to unplug all of the cords from the monitor, plug them back in and power on, but still getting the no signal message.

Any ideas?

That seemed to do the trick. It was the USB C touch cable that was sending the residual power.

The issue I’m having now is that when I power on the controller, the machine itself seems to be working. However, when I power on the screen, it now says no signal.

I tried to shut it off, unplug all cables, re-plug them all in, power on again, but still have a no signal message.

1 Like

You need to power the screen on before turning the controller on for booting up.

Ok, I’ll give that a try. Is it going to hurt the controller to turn it off via the rocker switch since I can’t access the screen to shut down properly?

Shutting down the controller improperly could cause the system files to become corrupted, so it’s always best to do a proper shutdown.

I’m asking because there is no way of shutting it down other than the rocker switch with the screen being in that no signal state. Correct?

Hey Trevor,

there exists a hack that preconfigures the Onefinity Controller to already know the display resolution at boot, so you don’t have to worry to turn on the monitor first. You can find it here, but you need to edit and save a config file inside Controller.

The explanation is, when booting up, the Controller tries to retrieve information from the monitor in order to know its resolution. If the monitor isn’t accessible at that moment (because you switch it on later), the Controller cannot set the monitor’s resolution. The hack above avoids this by setting the resolution in advance, so auto-probing at boot is omitted and resolution is always correct.


Hey Trevor,

if you establish a remote access by logging yourself in into the Onefinity Controller using ssh from another computer, you can enter the commands

sudo halt


sudo reboot

from there.


I’ll look into this today and let you know how I make out.

In the meantime, being a Mac user my entire life and now running / learning windows, I’m wondering what to do if I want to see my onefinity monitor screen on my laptop? I tried doing the access point, but it wouldn’t work (could be a windows firewall issue?). I then connected an ethernet cord directly from the controller to my laptop. I’m just not sure how to access the screen from there? I tried the http://onefinity.local option but it just comes up saying This Site Can’t Be Reached.

Any suggestions would be much appreciated.

Hey Trevor,

if you mention the “onefinity.local” URL I think you followed the text and video in
How to directly connect your Onefinity CNC to a computer/laptop (no screen present). Did you turn WiFi off on your Mac before trying? The reason is explained here.

But the most simple thing you can do is: On your Onefinity Controller display, there is an IP address shown, in the form “xx.xx.xx.xx” (“xx” being decimal numbers from 0 to 255). Open a web browser on your Mac, enter this IP address into the address bar, and voilà, you’re done.

If it does not work, there could be a number of reasons but problems can be solved. Many people use a remote computer to control the Onefinity, which has the advantage that you can see the camotics toolpath simulation which unfortunately the Raspberry Pi inside the Onefinity does not show on its display.

I noticed on my controller display that where there should be an IP address, it says IP: SSID:

This is what was throwing me off last night as I was just going to type in the IP address in a web browser window.

Hey Trevor,

but you have an Ethernet cable between your Mac and your Onefinity Controller, is this right?

If yes, what is the network information on your Mac Desktop?

Yes, I currently have the ethernet cable plugged into between the two. Being that I’m running windows on my Mac, navigating around is tough for me as PC is completely new for me.

With that being said, I did a search for Network and then found the ethernet info ( I think). Can I email you a screenshot so that it isn’t posted publicly?

Hey Trevor,

this would be possible, yes, but if you don’t mind, the timing is not so good, I have family time now and the weekend. It’s Friday 8 pm in central Europe, I am preparing to eat! Last beautiful golden sunrays of the day.

Also if it’s about network on Windows, I might not be the perfect person as I do not at all work with Windows and know not much about it.