Onefinity CNC Firmware 1.2.1 (2/8/23) (X-35/X-50 machines w/ Buildbotics Controller) (Outdated)

Firmware 1.2.1 releases today (2/8/2023) for all X-35/X-50 Onefinity machines with the buildbotics controller. (does not apply to elite series)

A little background.

Firmware 1.0.9 was the longest running firmware we’ve had up since release. It was solid, relatively bug free and very stable. We worked hard on 1.1.0-1.1.1-1.1.2 to add many new features and build on future additions to the firmware. We did private beta testing and in house, everything worked great. We gave it to a hand full of testers and, they too, had almost no issues. For some reason we skipped open beta testing to anyone who wanted to try and released it to the public. Unfortunately, with the larger sample size more bugs were found and with the many major changes it became harder to squash the bugs. We made some human errors and rushed out what we though was ready to go in excitement of getting these features out to everyone.

After a few weeks it became apparent that 1.1.0 and 1.1.1 had enough bugs we couldn’t recommend installing it and resumed installing 1.0.9 from the factory. Unfortunately, we couldn’t ‘turn off’ the ‘update available 1.1.1’ when you connect your controller to the internet as some users are already on 1.1.1 and we’re unsure if it would break their machine or stop their ability to auto update forever, so we left it up.

What are we achieving with 1.2.1 firmware?

Todays firmware release may seem like we’ve moved backwards, but allows us to do 3 things;

  1. We went back to the fresh and stable release of 1.0.9 and added 5 changes and bug fixes. This means that 1.2 will not include all the enhancements that 1.1.0, 1.1.1, and 1.1.2 alpha included. This is to ensure you have the most stable firmware you can possibly have on your machine and avoid any unforeseen issues bugs may cause.

  2. This also allows us to essentially ‘skip’ 1.1.0 and 1.1.1 upgrade notifications users would have when connecting their controller to the internet and now it will show the 1.2 update bypassing the buggy 1.1.X releases.

  3. Support the newly released Z-20 Heavy Duty Z Slider (by adding default configuration settings for it to the reset configurations setting in the firmware)
    See: Installing the Z-20 Heavy Duty Z Slider (configuring the software)

What are the changes from 1.0.9 to 1.2.1 firmware?

  • (bug) Fixed bug when uploading files with special character or spaces in the file name (like . _ ?*&^&, etc.)

  • (bug) Max usable file size increased from 100mb to 1gb

  • (bug) Fixed long/slow movement bug (mostly seen in laser movements that would case the machine to skip steps with long movements under 15~ ipms)

  • (Add-On) Display can now be rotated 180 degrees

  • (bug) Fixed an issue when the most recent file uploaded wasn’t automatically made the active file.

  • (Visual) Added a visual change of the logo header and IP address/ssid/firmware version in the header

  • (Setting) Added to the ‘reset configuration’ to include choosing which Z slider you have currently installed (Z-16 original or the new Z-20 Heavy Duty).

Where can I get 1.2.1 firmware?

If you are connected to the internet with your controller, a upgrade pop up will be at the top of your screen and can update by tapping that notification. If you are offline and want to update, you can do it via USB by going to our links below:

Important notes:

1.2.1 Known Issues.
There is a known file issue bug. This will sometimes run the wrong file than one selected. Sometimes you cannot delete files on the controller.
These two bugs are fixed in 1.3 firmware.

What about the future?

Starting with this release and going forward, all release will go though the following testing phases. 1: internal testing 2: private beta testing 3: public beta testing via the forum 4: Public Release.

This schedule of releases ensures the firmware to be the most stable releases we can possibly make.

My X-35/x50 Machine hasn’t shipped yet, what firmware will it have on it?

If your machine hasn’t shipped yet, it will arrive with firmware 1.2.1 preinstalled. You will not need to update your machine upon arrival.

What about the Elite Series ft/Masso firmware?

There have also been concerns that our original controller firmware development will be halted since the Elite Series has come out with the Masso controller. This is in fact not the case. The development team that works on our original controller firmware will not be involved in the Masso firmware development, and have actually grown in size! Massos’ developers are a completely separate team devoted to their own controller.

Speaking of future, what comes after 1.2.1 firmware?

The next firmware version of the software, 2.0 is a major software revision. What do we mean by ‘major’? Visually, and functionally, it will look and work very much the same as our current firmware (1.2). However, it’s underlying programing is moving to 64bit architecture, which means major, under the hood, work. What does moving to 64 bit mean? In simplified terms, it allows us to change from the current older raspberry pi 3b computer module that’s inside our controller today to the raspberry pi 4 computer module.

The biggest visible change a user will see is that the 3d preview is now available on all original controllers with 2.0 firmware (as it was only available previously on a networked computer).

We will be releasing 2.0 with little-to-no new features to ensure the most stable firmware.

Once we’re sure 2.0 is as stable as can be, we will be slowly implementing all of the new features of 1.1.1, 1.1.2 and many more features into firmware 2.1 and beyond. A gradual release of features should enable us to avoid buggy releases in the future.

One thing to note as of 2.0 firmware:

Due to the major underlying bootloader updates, it will REQUIRE physical removal of the sd card in the controller and flashing via a computer. A micro SD card reader is required. (recommended if you computer does not have one built in: ). You will not be able to upgrade from 1.X to 2.X of the firmware without flashing the entire OS via a computer. It’s a simple process, detailed in full here:

Can I test 2.0 now?

Yes! We need more beta testers to make 2.0 as stable as possible! Follow this link for more information:

*Notice: this can have bugs and is not recommended for production shops

Where can I report bugs I come across in firmware?

You can report bugs in their respective forum threads:

  1. 1.2.1 Firmware thread in the comments of this post.

  2. 2.0 Beta Firmware thread here: 2.0 Alpha Test Build #0 (outdated)

Where should I not report bugs?

The worst place you can report is on the Facebook group. No developers monitor the group. Always use the forum (above links) to report bugs.


1.3.0 Alpha 1 is released here:

Onefinity Reserved post #2

Network issues Buildbotics:

  • I have been using the Panda Wireless PAU06 300Mbps Wireless N USB Adapter on the controller since November 2021 for wireless connection while on 1.0.9. Only issues was changing IP address
  • Moved to 1.1.1 and network became flawless. Never dropped and IP never changed.
  • Flashed MicroSD to new 1.2.1 and did reset instruction, now no network found
  • Used phone as hotspot then “restarted” controller. Both phone network and house network visible.
  • Selected house network and entered password, clicked OK which restarted the controller
  • When powered back up, no more network
  • Several “restarts” and “power down” did not bring them back

USB adapters are not supported other than this

How far away is your router/extender from the onefinity? It must be within 10ft and clear line of site, as stated in all documentation and videos.

1 Like

Wasn’t aware of that. When I bought the machine this adapter wasn’t listed and the one I have been using I have had for more than a year with no issues until the update. I will buy the one you list. Router is much farther then 10 feet, but I’ll bet that’s the same with quite a few folks.

Then the problem is now with the onefinity or 1.2.1 software, your issue is not being within the requirements of wireless networking.

1 Like

Yes sir. I understand. But it did work, and now it doesn’t. The only change being the firmware.

1 Like

In terms of firmware, it’s moot, as you’ve been using an unsupported adapter and have been outside of the requirements for wireless networking.


Out of curiousity, can the software affect the networking of the base controller configuration?

Case in point:
1.09 firmware had no issues with network at 25 ft
1.1.1 could not find network at all, even settin a netwotk on my phone less than 1ft away. Also added an wifi extender at 5 ft direct line of site and still no network
1.1.2 was able to find the extender but would never get an IP address
Flashed 1.2.0 able to connect to main network 25ft away but not the extender, same isse with 1.1.2
Upgraded 1.2.1 no network issues , able to connect to main network or extended network with no issues.

Cool beans Ron! Are you using built in antenna and the extender?

1 Like

Built-in Antenna. I put in a WIFI extender to get closer to the machine to overcome the software issues based on the feedback… so I meet the criteria and the network still didn’t work… but each version / update seems to have change the behavior of the network working on the controller…

Thanks Ron. I want a mesh system when prices become more reasonable. I think that would help. I’m gonna remove the antenna I have and see if it works with my phone near by as a hotspot just out of curiosity. For me the middle version was great, at least on the network side.

I will have to pull some gcode for you, but the main issue I’m dealing with on 1.2.1 is that on numerous occasions, it has started carving the default demo design even after loading and previewing my gcode. If I take the same gcode and reselect it a couple times from the drop down, I seem to not experience that issue. I don’t have definitive steps to reproduce it yet, other than loading in a new gcode file. I’ve noticed that sometimes it doesn’t preselect it in the dropdown for me after uploading it, and I have to do it manually. It’s possible that it’s always after that where it starts the faulty job, but I’ll try and get more solid data.

I had the same issue when I flashed from 1.1.2 to 1.2.0. Once I pulled the 1.2.0 to update from a USB drive again, the issue went away. Seems odd that the flashed version had the issue, but the upgrade version corrected it. It may be the same with the 1.2.1 if you flashed it. I went from 1.2.0 Beta to 1.2.1 using the USB method, as the network check wanted me to load the 1.1.1 version. It was a mess… but once I did the upgrade from the USB version, I also went to the internet and updated it again from there… seems like overkill, but it appears to fix some of these minor issues.

1 Like

Did you try doing a complete image and not upgrade? Someone saw this during beta and started with a fresh image and all went away

I did a full flash. Maybe I’ll try it again. 99% sure it was from the image in this post.

1 Like

With the wifi issues… If it is not connecting at all… If I remember the ssid and passwords are case sensitive. It bit me when I first set things up.

I use the canakit wifi dongle and my wireless ap (ubiquiti) is about 15’ away


Before I replaced my home wifi setup, the signal strength was not strong enough to connect to the controller. I bought a wifi extender. Plugged that in near the controller and never had any more connection problems. The extender has a much more powerful antenna than the controller, so it can bridge the gap… Setup was simple.

Here’s an Amazon link: $16


Many people had problems re-using sd cards when reverting from 1.1.x to 1.09. I know it’s an extra 20$, but I am just replacing the SD card anytime I have to manually flash it. Haven’t had any issues from firmware changes.