Firmware Update 1.0.7 (3/17/2021) (Outdated Firmware)

1.0.7 is the forth firmware update for the Onefinity CNC Controller.
This is a MAJOR release. A lot has been fixed, updated, and improved. We’re investing more effort into improving the software and want to thank the team who’s been working hard doing so.

How To Install:
Updating via USB
You’ll do an update via USB using the following steps:
Copy the blue .bz2 file below onto a usb stick (it must be formatted as fat 32 or ntsf). Click the flyout menu (three bars on top left), general, under firmware click ‘UPLOAD’. Select the 1.0.6 file. Depending on your shipping date, the password to update will either be buildbotics or onefinity

Updating via the Internet:
If you already have 1.0.6 and below and are connected to the internet and have auto updates on, a pop up will inform you that there is an update and the machine will update automatically via the internet.
If you already have 1.0.6 and below and are connected to the internet and do NOT have auto updates enabled, go to Click the flyout menu (three bars on top left), general, and under firmware click upgrade.

onefinity-1.0.7.tar.bz2 (2.1 MB)

Change Log:

  • Cleaned up UI layout a bit on the main screen
  • Enabled auto expansion of partition and file system to fill SD card on first boot
  • Added probe continuity test before probing (pop-up dialog)
  • Added a popup after probing, reminding the user to put away the probe
  • Lowered default probe seek speed
  • Fixed file drop-down menu showing old files
  • Added file system watcher for uploaded files
  • Improved support for large gcode files, improves performance on Raspi
  • Fixed a bug where the UI could become unresponsive at boot, or when uploading the first gcode file
  • Changed default max-deviation to 0.001 to reduce issues with chattering while cutting arcs and circles
  • Hides ratpoison (window manager) message during boot up
  • Disabled G61, G61.1, G64 gcodes until the root cause of circle chatter is identified and fixed
  • Increased icon size on the main GUI
  • Improved version comparison logic for handling public beta releases in the future
  • Changed default max-jerk to 1000 for X/Y axes
  • Changed default idle current to 1A
  • Force-set some critical configuration values to help with reliability
  • Metric units only for junction-accel and max-deviation
  • Rewrote the homing procedure to be more consistent
  • Small improvements to the stall homing procedure
  • Fixed error messages in the console (webgl)
  • Fixed styling bug with error dialog
  • Added a setting to allow enable/disable of probing safety prompts
13 Likes

I did my update last weekend 1.0.7 do I kneed to refresh it with this one (3/17/2021)

Yes, If you have installed ANY beta versions of 1.0.7, you MUST install this version. If you’re connected to the internet, you will be prompted to install this final version.

5 Likes

Awesome work Team! Love to see the final release of new enhancements.

-Alex

How long does the update take via the web? I feel mine has been updating for too long. Should I estop or turn off n start again via file?

It should only be a few minutes at most.

Hopefully you’re already past this?

1 Like

Is the bug that needed probing to be done in metric corrected in the final?

2 Likes

Yes, the probe bug is fixed.

3 Likes

It should only take up to 4ish minutes. If it hung, turn off the controller. Make sure you’ve used UPLOAD button if using a usb stick.

2 Likes

If someone has the beta version already, it takes less than a minute. At least from my most recent experience.

1 Like

The system is asking for a password when I try to upgrade from 1.05 to 1.07 via the internet. It will not accept “buildbotics” or “onefinity” as I read elsewhere. Any suggestions?

1 Like

Not sure what to say except check with customer support. My controller accepted the onefinity pass code and updated quickly from the beta version. Good luck.

Perhaps your spelling them wrong or using capitals? It’s either on or the other (more than likely onefinity though. Ensure your not putting in the “ “ marks.

I believe the password is “onefinity”. I saw that in another post somewhere. And that worked for me upgrading from 1.0.5 to 1.0.7.

I was greeted this morning by “upgrade” on the 7" screen. It worked perfectly. I noticed homing was a little more solid, the GUI improvements are most welcome and my probe worked perfectly. My motor 0 and 1 max-velocity settings previously changed were the same. Probe speed 75/25 was the same and Imperial in both places. No problems noted. Onefinity has done a great job. I assume we are not doing
restore defaults this time?

2 Likes

Thanks OneFinity. Took a couple minutes through the internet with no challenges. I appreciate the teams hard work and continued commitment and support!

Hey all,
So, for reference, I’m a 26 year tech support professional and am pretty good at the whole 'make sure you are using right case" thing. I’ve tried:

onefinity
Onefinity
OneFinity
buildbotics
Buildbotics
BuildBotics
password
Password
PASSWORD
(no password at all)

I have cut and pasted the passwords to confirm I am not misspelling anything.
I have done this via the web interface and directly on the touchscreen.
In every case (literally, every case) I get the same result.

Did you perhaps change the password using ssh at some point?

Martin

Only odd thing that I noticed on my 1.6 to 1.7 update (which was super smooth and prompted me the min I fired my OF up) was that after the install and reset of settings, it lost my Wi-Fi password.

After re-entering and a reboot, everything was perfect. Just thought it was noteworthy

-Alex

It looks like you are in a remote interface, have you tried inputting either “buildbotics” or “onefinity” into the touchscreen directly? Worth a shot if you have not. In the past I have found the RI to be slightly off timing wise.

-Alex