Firmware Update 1.0.8 (5/5/2021) (Outdated Firmware)

1.0.8 is the fifth firmware update for the Onefinity CNC Controller.

How To Install:
Updating via USB
You’ll do an update via USB using the following steps:
Copy the blue .bz2 file below onto a usb stick (it must be formatted as fat 32 or ntsf). Click the flyout menu (three bars on top left), general, under firmware click ‘UPLOAD’. Select the 1.0.8 file. Depending on your shipping date, the password to update will either be buildbotics or onefinity

Updating via the Internet:
If you already have 1.0.7 and below and are connected to the internet and have auto updates on, a pop up will inform you that there is an update and the machine will update automatically via the internet.
If you already have 1.0.7 and below and are connected to the internet and do NOT have auto updates enabled, go to Click the flyout menu (three bars on top left), general, and under firmware click upgrade.

onefinity-1.0.8.tar.bz2 (2.1 MB)

Change Log:
-Fixed chatter and lost steps issues (most commonly seen by Fusion users), re-enabled support for G61, G61.1, G64.
-Fixed 3d preview on Safari-based web browsers (MacOS & iOS)
-Made it less likely for a user to upload a non-gcode file (lots of new users were mistakenly uploading the design file)
-Fixed problems with UI freezing when attempting to process a non-gcode file
-Simplified error popup to make it less confusing
-Improved error messages for most internal error


G61, G61.1, G64 would seem to be useful. Do we need to get post processor changes to enable?

Hi Russ - likely. The post processor would have to include those codes in the output. Though I’m still struggling to see the utility in a real world situation - I just need to do more research.


How long does an update usually take on the Internet? I selected update and it’s been running for about 15 minutes still on the firmware upgrade please wait window

I took the internet out of the equation and used a usb drive. I turned my back and it was done.

Well, now what.
It was locked up updating over the internet, so i turned it off and back on to update via the usb, and now it won’t boot up at all.
Onefinity?? now what?

No monitor or fan either. DOA. Any way out of this?

No fan!!! At first I was thinking of a corrupted sd card (if you want to reflash it unzip the file and follow ( Installing operating system images using Windows - Raspberry Pi Documentation ) It’s 1.0.7 so you will have to upgrade again. Suppose to be very fast.

@OnefinityCNC was there ever a fix for the laser not turning on with the MDI commands after the laser was homed?

I updated via internet and it took maybe 30 seconds.

This is going to be worked on in the next update…

@onefinitycnc I sure hope so, it takes a lot of time turning it off and back on between every project.

Control view regressed in v1.0.8b1, can not click 'set zero' or 'home' after playing and stopping gcode. · Issue #49 · OneFinityCNC/onefinity-firmware · GitHub This probably didn’t make the cut.

What password to upgrade did you use please? It won’t take onefinity for me.

password to update will either be buildbotics or onefinity

I had the same problem but if I remember right I tried no password and it took.

Just confirming… you can update via Web Interface if say using a laptop to control the 1F?

Seems to be stuck here on “firmware upgrading, loss of power, etc…”… 30 minutes – high speed internet otherwise…?

Yes Matt you can do it from the interface as well. I’ve done it that way twice. If its stuck I would reboot as it should only take <30 seconds.


tried upgrading from controller and web interface, stuck on both


Did you try shutting down and rebooting, then try to reinstall? If that does not work then you probably need to send a note to support as that should work.