Firmware Update 1.0.5 (10/15/2020) (Outdated firmware)

1.0.5 is the second official firmware update for the Onefinity CNC Controller.

the password to update will either be buildbotics or onefinity

Updating via the Internet:
If you already have 1.0.4 and are connected to the internet and have auto updates on, a pop up will inform you that there is an update and the machine will update automatically via the internet.
If you already have 1.0.4 and are connected to the internet and do NOT have auto updates enabled, go to Click the flyout menu (three bars on top left), general, and under firmware click upgrade.

Updating via USB
Copy the blue .bz2 file onto a usb stick.
If you already have 1.0.4, Click the flyout menu (three bars on top left), general, and under firmware click ‘upload’. Depending on your shipping date, the password to update will either be buildbotics or onefinity
If you have 1.0.2 or no network connection you’ll do an update via USB using the following steps:
Click the flyout menu (three bars on top left), general, under firmware click ‘upload’. Select the 1.0.5 file. Depending on your shipping date, the password to update will either be buildbotics or onefinity

Download here:

onefinity-1.0.5.tar.bz2 (1.7 MB)

1.0.5 Change Log:

  • Changed the jog commands so that save/restore modal states are not used to avoid situation where spindle/loads could turn back on if the stop button was used instead of the M5/M9 gcode commands.
  • Added tool path status to control page
  • Added an explanation popup when touching/clicking on a toolpath status
  • Moved over/under/no-fit warnings to tool status from machine status
  • Added new pop up with clearer wording when toolpath will go beyond limits
  • Added “home machine” pop up on start if the machine is not homed
  • Home message formatting
  • Home message would pop up when jogging or E-stopping
  • Spindle turns back on when using XY zero or Z zero jog buttons if turned on with MDI command and then e-stopped
  • File drop-down now tries to expand to fit the longest file name
  • New values for probing (must reset machine config to obtain)
  • Added IP: and SSID: for clearer understanding of each

Picture explanations:

Machine now asks if you’d like to home upon startup. Hitting cancel will skip homing:

Homing is now more clear. Homing and toolpath success/fail/warning are now separated. File name bar now shows complete file name
(picture shows successful Homing (under state) and toolpath will fit (under toolpath):

Over Toolpath. If a toolpath shows ! OVER, the current toolpath file will move above the axis limit (in this case, the Z would try to move higher than it physically can:

Under Toolpath. If a toolpath shows ! UNDER, the current toolpath file will move below the axis limit (in this case, the Z would try to move lower than it physically can:

No Fit. The model is to big for the cutting area of the machine. The machine will not attempt to cut:

Toolpath status can now be touched/clicked to give a explanation as to what no fit/under/over/ok mean

IP: and SSID: are now separated for easier viewing

Probe movement has been slowed down (previous settings could cause the probe to physically move when probing). Because this is a configuration setting, you’ll need to reset configuration (choosing your correct machine model) for this to take affect:

Reset Config selection is located under the general page, reset:
Warning: if you have custom values (homing settings or probe size for example) and reset configuration they will be lost. Please take note of your custom values before resetting so you will be able to reinput them

Don’t forget to use the new shutdown button before turning off your controller (added in 1.0.4)

How to select the usb stick for upgrading offline:

6 Likes

I tried to update over my ethernet but it asked for a password and I don’t remember ever setting a password??

Hey Edward… If you are referring to the password required to update the firmware, “Depending on your shipping date, the password to update will either be buildbotics or onefinity
Please let me know if you require further assistance. Talk soon…

Great work OneFinity Team!!

Installed this first thing in the morning and ran it through the paces. Love the pop-ups on returning to zero to protect fingers and work. Did not try the spindle turning off after jog but the rest of the enhancements are great.

Thanks again for spinning these enhancements so quickly while your shipping out orders as fast as possible… VERY IMPRESSIVE! :metal:

Cheers’ :beers:
-Alex

1 Like

So I did the update and it doesn’t show me my IP address or SSID. It shows IP SSID but nothing else. I tried rebooting multiple times and put my password in multiple times as well. Before I did the update it showed me my IP address but that was it. I also have to put my password in every time I restart the unit. Is it supposed to save it so I don’t have to do that every time I turn it on? Please help me and thank you. BTW I have the woodworker.

How long is it supposed to take to upgrade? I’ve had my usb stick plugged in and entered password. Says firmware upgrading…please wait and warning about loss of power. It’s been over 5 minutes but it hasn’t completed.

Try restarting your router and then the controller. If it doesn’t show an ip address it’s not making a connection to the router.

1 Like

it should only take 3-5 minutes. it’s possible that all the ‘bits’ didn’t download or transfer to the usb. Turn off the controller and give it another try.

1 Like

That worked !!! This is one of the main reasons why I got the Onefinity CNC. I love the level of customer service that you deliver. Thank you so so much for being you.

3 Likes

thanks james! Glad you got it going!

2 Likes

That took care of it. Thank you

2 Likes

Onefinity for me. The homeing does seem more smooth now.

3 Likes

Do you have to update to 1.0.4 before 1.0.5?

you should not have to.

1 Like

Thanks for the update Onefinity, homing is easier for me now.

1 Like

Hi
As firmware updates are really important, can you kindly put a link to this in the Announcements section? (Ditto for new products). Thanks!

Couple of possible bugs with the latest firmware:

  • The homing popup shows up on both the touchscreen & any external connection. If you home on the touchscreen, the other screen doesn’t close the popup (not a major bug, but annoying)
  • When running a file, with the machine default settings set to metric, with a file in imperial, once the file completes… the whole interface switches to imperial. not during the execution, but after (still need to confirm again)
  • physical E-stop button also turns off the controller & monitor - which seems weird, wouldn’t it be more logical to just cut power to the stepper motors through the bios instead of essentially restarting everything? the E-stop on the screen leaves the controller & monitor running, but the physical button acts different
  • Physical e-stop button resets the 0 position to wherever the machine was when it was e-stopped - is this intentional?
  • The Z axis soft limits sometimes prevent probing (for short bits, ie: surfacing bit). One issue I have with this is that even after getting the warning, then going into the settings for the motor and changing the value, saving and then trying to re-probe - the error still happens, but still based on the original value; the probing mechanism doesn’t seem to look at the new settings.

The physical E Stop is directly wired to the power supply, pushing it kills all power to the machine. It’s a complete shut off of power, which will reset the controller and any values it had before pushing the button.

2 Likes

Is there a wiring diagram for the E Stop if we want to include router control? Could a solid state relay be used with the L1 or L2 to control the router?