Connect laptop to controller

I have previously connected my laptop ( several times) to 1f controller with no problem. For the last several times I have tried I get the following error message:

Can’t convert ‘int’ object to str implicitly

I do not have wifi or internet in the shop. Shop is not close to the house and have not installed cable for internet.
Any helpful suggestions will be appreciated.

Please explain how you connect it

On controller: Admin , mode set to access point
channel: = 1
name: onefinity machine
enter password

On laptop:
in browser enter http://onefinity.local

This worked for several weeks, and now for the last 2 or 3, I get the error.

Did you do the 1.0.9 firmware upgrade? Any wi dows updates to the laptop?

I assume you are connecting to the wifi of the pi with the laptop?

no 1.0.9 upgrade and no window upgrade and yes I am connecting to the wifi of the pi with laptop.

Is the error on the controller screen or the laptop in the browser? Also have you tried other browsers? Is it on load or is it when selecting a file?

My recommendation would be to get a cheap wifi router for your shop. You don’t HAVE to have internet, but the wifi router would put them on the same wireless network and they’ll hookup easily.

You can’t go wrong with a TP-Link like this

If you want internet in your shop, you can Google for some Ubiquiti products that allow very long wireless runs.


I have mine connected to the laptop directly. And it works every time. I have a wifi adapter/extender in my garage and the controller is a foot away. It would work sometimes but was inconvenient. This is the reason I wait a while before updating firmwares. To see if the “qweks” get worked out. But because you haven’t updated, you might have a different problem. Check your network settings on your Lan port.

Hey Jim,

you did not answer the question where this appears.

  • Does this appear in your browser?
    [   ] yes   [   ] no

If yes:

  • Is the application page of the Onefinity Controller already running in your browser when this error appears?
    [   ] yes   [   ] no
1 Like

Hey Jim,

anyway this is a python error. Application runs a few python scripts at startup to check some things and obviously some case occurs that the developer did not prevent or think of. Write to, but try to include a list of everything needed to reproduce the error.

1 Like

ono the controller screen

  1. no, on the controller

`Here is screenshot of controller.

Try reflashing the OS and then try connecting to wifi again: How to reflash the operating system on the Onefinity (Full SD card image)

It may also be the space in the ssid name or the password.

Most likely the odd characters (space) in the ssid or password.

removing space did not change anything, same error. Going to reflash the OS.

Reflashing proceeded as described.
Machine booted normally.
When selecting shutdown, the following screen screen is displayed and never shuts down.

Hey Jim,

Space in ssid or password is allowed, however passing it over inside the application is subject to input sanitizing.

If this is the cause of the issue, please be aware that SD cards are subject to wear and also may be of poor quality and may fail totally very suddenly. I had a SD card of EMTEC brand bought at Aldi in use as Operating System SD card in a Raspberry Pi, and from one day to the other there were so many writing errors that the system failed and I had to throw the SD card away and replace it. Luckily was able to rescue some configuration files. So if you reflash, be aware that if your SD card could be the cause so reflashing won’t help then, only buying quality brand, e.g. Sandisk. Note that for a Raspi 3 you don’t need the fastest SD cards.

This is the original SD card that came with the Onefinity.
I got the unit in September of 2021.
Could the Onefinity SD card that is only a few months old be the issue?