Connecting to wired network

I have unrealiable WiFi connection in the garage where the machine is located.
I’ve previously been able to connect to the wifi network on the machine, but it does drop, as well as often does not connect on startup.

Instead, I’m trying to connect via an ethernet cable, but having difficulties. I’ve plugged in the network cable, and booted the machine, but it doesn’t seem to connect to the network.
I’m connecting via a mesh network system, and hardwired to one of the access ports.
I have other devices that can connect, laptops, and a 3d printer via this network cable, so I’m certain it’s not a cable/AP issue.
Yet the onefinity machine doesn’t seem to connect to the network.

Is there some else I need to do to get the machine to connect to my local network?

1 Like

There shouldn’t be anything you need to do to enable the ethernet connection on the Onefinity controller. I’d suggest testing the connection by unplugging the cable from the Onefinity controller and plugging it into a laptop or other device if you have one. Also you can test the Onefinity controller by plugging it in back to back to with a laptop as well.

1 Like

The same network cable has been tested and proven working on other devices such as laptops and a 3d printer (Paspberry Pi)
It’s only the onefinity that seems to be struggling to connect.

I’m not exactly sure how to get the machine connected via laptop.
I’ve tried this method,

But it doesn’t work for me. turning off WiFi and attempting to load onefinity.local just time out

These look like instructions to “hardwire” a laptop to the onefinity not via the network. But what you done connecting to a network hub should work.

Is it your onefinity not seeing the network or your pc not seeing the onefinity. Does the onefinity browser let you, for example, reach the bbc website via

1 Like

Have you tried connecting a laptop to that ethernet port?

Typically there are only 2 reasons why a wired connection doesn’t work properly -

1 - bad cable (all ready ruled out)
2 - Failure to get a valid IP address (DHCP)

Assuming you have a flat network without any VLANs, DHCP should not fail unless your router has MAC filtering turned on or your bridge is not passing broadcast packets for some reason.

If you do have VLANs, you need to make sure your DHCP server is providing IPs on that VLAN. Generally broadcast packets will not traverse a VLAN or a VRF.

A possible 3rd failure mode is duplicate IP addresses, but that is very rare and any properly configured network should not have that problem.


  1. I assume your mentioning “hardwired to one of the access ports” as being one of the half dozen (or so) ports on the back of your Internet modem. If so, then one thing I can suggest here is to try swapping ports with something else.

  2. Confirm you cannot see an IP address on the top of the Onefinity control webpage when powered on and idle

  3. Do any of the lights on the network cable JACK on the Raspberry Pi (or on your modem/device) either blink, or even briefly flash at all when power is first applied? Sometimes there may be lights without having turned on the Onefinity, but make sure it is on and idle

  4. If you know how, try logging into your modem’s web interface (e.g. is default for many networks) and see if you can identify the Onefinity as being recognized and/or what its IP address is showing

1 Like

Try opening a terminal window by plugging in a keyboard to the controller then hold the Ctrl key, press T then C and let go of the Ctrl key.

Next type "ping” this called the loopback address and will test the ethernet port of the raspberry pi to make sure it is working, this should work with or without a cable plugged in. It should look like this.

It sends test data to the destination IP and lists the response. I think it says something like destination unreachable or something when it fails. Hold the Ctrl key and press C to stop the ping. If this works the ethernet port of the controller is good.

Next make sure the cable is plugged in and use the ping command again but this time use your router IP instead of the loopback. The router should respond the same way with no lost/dropped packets. If it can’t ping the router it’s probably a physical connection issue at the ports or in the wire. If it can ping the router it’s usually a software issue like a firewall or some setting in the router blocking the controllers access.

To get back to the controller display hold Ctrl, press T twice and let go of Ctrl.

Hey Chris, hey all,

but is the localhost, which means, it pings itself with this command. Using the loopback interface bypasses any local network interface hardware. I would rather type “ifconfig” to see to what ip address the network hardware is configured, and “netstat -r”.

1 Like

Hi Aiph5u,

Yes the loopback address is a self test to check for faulty local ethernet adapter hardware . They rarely go bad but if it fails there’s no chance of talking to anything else on the network and the raspberry pi would have to be replaced.

Yes ifconfig would work too. It would also have the added benefit of showing the ethernet adapter network settings. If the ethernet adapter/hardware was the issue the ifconfig should fail too.

Hey Chris,

you cannot check for faulty local ethernet adapter hardware by using the loopback device, as per definition it never passes any packet to a network hardware.

What you can check with pinging the localhost is if you have a TCP/IP stack installed.

1 Like

As Aiph5u said, pinging hits the software based loopback interface not any physical interface. Fun fact - you can ping any address beginning with 127.x.x.x and it hits the loopback interface.

1 Like

Thank you all for the suggestions. I’m going to give these a shot, the in a couple of days once I’m back at the shop

Ok, I I guess I learned something today. In school I thought that our instructor explained it the way I did. Thanks for the lesson guys :grin:

Hi AmazeCPK,
If the wired connection gives you too much trouble you could try using a small travel router mounted on the onefinity in repeater bridge mode too. In repeater mode it would recieve the signal from your network routers wifi amplify and resend any signals. There are many different models and prices but they are all small, slightly larger than a deck of cards. They would need to have the repeater mode though. Here is a link to the first one I found on Amazon.
GL.iNet GL-SFT1200 (Opal) Secure Travel WiFi Router – AC1200 Dual Band Gigabit Ethernet Wireless Internet Router | IPv6 | USB 2.0 | MU-MIMO | DDR3 |128MB Ram | Repeater Bridge | Access Point Mode

Hey AmazeCPK,

when you connect a HDMI monitor to the Onefinity Controller (and there is an ethernet cable between Onefinity Controller and remote computer), are you seeing an IP address on top of the page, like this?


The method described in the video uses will automatically establish a ‘link-local’ IP address with the zero-configuration networking that is installed on Onefinity Controller. This means, you would see a 169.254.x.x address on top of the display (or when typing ‘ifconfig’ on the CLI), as shown in the image above. Is this the case when you connect with an Ethernet cable?

If so, you can type this IP address into the address bar of your web browser on the remote computer, and you should see the Onefinity Controller User Interface (UI) and everythings works then.

Additionally, the Onefinity Controller offers Name Service Discovery to resolve addressing with the name ‘onefinity.local’. It does this with the Linux common implementation “Avahi” that uses mDNS. However this is not supported on older Windows OS.

Are you using Windows XP/Vista/7/8? In this case you got to install an additional package for the Name Service Discovery. This will then allow you to simply type “http://onefinity.local” into the address bar of the web browser of the remote computer.

But simply using the Onefinity Controller’s IP address (as shown above) by typing it into the address bar of the web browser of the remote computer should always work.

1 Like


Did you ever get this working? I was honestly wondering if the networking interface was down for the ethernet port. The command that you’d use on the terminal to check is slightly different depending on the distribution of linux that’s operating. If I recall, BuildBotics is running a Debian variant. You can check with this command in the terminal:


Now, that you know the correct linux distribution, run the correct command to check if the ethernet interface (eth0) is up or down, or restart either the dameno using the init.d or systemctl. Check for reference here.

All of the other comments that were mentioned about MAC-filtering or cables hold true. I gathered from the thread that other devices connected via the wire have networking and only the BB controller is being a royal pain. If for some other unrelated reason the system seems frozen and you can’t reboot it, you may try the following from the terminal:

sudo reboot

Translation: (super user do reboot)

Some systems complain about the reboot command. If you ever need to shutdown and cannot use reboot, try the following:

sudo shutdown -r now

Translation: (super user do shutdown remaining time immediately)

More random tips:
If you’re a Linux or a Mac user, you already have built in access to a bash-shell or z-shell via the terminal on that operating system. If you’re a Windows user, you can download a tool called PUTTY to simulate having a shell in a windows system. You would use the terminal or PUTTY to make a connection via SSH (secure shell) where the username and password are here. The proper format is username@ipaddress, so: bbmc@192.169.*.* (replace * with your last two octets for your IP). Press enter and then enter your password when prompted.

Why would you care about SSH. If you didn’t have a spare keyboard or the OneFinity display has issues, etc… Rather than plugging in a monitor and keyboard to the BB controller, you can have control via ssh from your computer as if you were actually sitting at the pi with a monitor and keyboard. Initially, you’d have to rely on WiFi to ssh, but you could take a look at the networking interfaces as described in the link above. If you manage to get eth0 working, you could then check your IP address on the controller’s display to see if it’s ethernet or WiFi. You’d know this based on the output for the networking interface linked to above.

if config | grep 192 -B 1 -A 1 --color

Translation: (list the network interfaces and filter for 192, showing only the matching line and +1 line before and after any matching result of 192, and colorize it so I can see it easily). Assuming you haven’t done anything crazy like remade your network to become 10.*.*.*.

To exit ssh, simply type exit and press enter.