Connecting to a wired network

The controller manual and the online video do not directly cover the steps for connecting the controller to a hard wired network, using Ethernet cables, through a router. As most shops can have difficulty with wi-fi due to electrical interference, it would be a preferred way to connect the controller to home PCs.

The controller manual does not cover connecting to a network of any kind and the video uses the wireless system.
Douglas

All you do is plug in the Ethernet cable to the port in the back of the router. If your router uses DHCP (as most do) an address will automatically be assigned to the onefinity controller. If you are accessing the controller from another computer you may want to reserve an IP address as explained here.

2 Likes

Well, it was not as easy as “just plug in the cable to the back of the router” But, I was able to get it all connected, can now view the controller on a large pc monitor, being able to use keyboard and mouse to navigate. Big improvement over the 10in touch screen. This will offer many advantages when using the 1F machine, and changes the experience substantially. Highly recommend connecting your 1F to a wired network and pc.

2 Likes

Douglas, were you able to connect via the ethernet cable? and how did the process work? I though it would be just plug an play. I connected the controller with ethernet cable. It shows the new IP address but when I punch in the new IP address on my laptop, it does not find the controller and doesn’t connect. Any suggestions or settings I need to change?

Hey Kamran,

Modern browsers often select the https protocol by default, which does not work with the Onefinity Controller

1 Like

Does typing in the IP address, such as 192.168.xxx.xxx auto change the http to https? If that is the case I’ll try to pay close attention to that next time I boot up the 1F.

Previously I was connecting to 1F via Wireless Connection. Since the 1F was connected to WiFi I would simply type the IP address in my browser, but the connection was hit and miss. Even though my 1F controller is sitting about 5 feet from the router (specifically installed in garage for 1F) at time the web browser would not load the page. Therefore, I connected via the ethernet.

Now that I have connected it via wired connection, it shows two IP addresses, one for wifi and one for wired. The wired IP don’t work but still the connection via wifi is hit and miss. I am not sure what I need to change to have this resolved.

If any of the geeks in the 1F forum know about this issue I would love your assistance.

Hey Kamran,

Modern browsers can be set to prefer https or even to allow https exclusively (some are set this way by default).

The Raspberry Pi 3B that is inside the Onefinity Controller has WiFi capability, but the Onefinity Controller aluminium case acts as a faraday cage which shields the radio waves. Unlike other small single-board computers, the Raspberry Pi 3B has no external WiFi antenna socket.

Therefore using Ethernet is the good choice, also because a workshop is usually a place with many sources of EMI.

The Onefinity Controller is configured to do zeroconf address creation. This means, if you have a computer, a notebook or a tablet, you can connect it to the Onefinity Controller without having to configure the network connection. But if you have a DHCP server in a router (not a router :slight_smile:) in your LAN, this is another way to get an address automatically. Look at the router’s log to see if the Onefinity Controller appears there.

Are you using Windows version<10? If so, you may be interested in this:

See also

1 Like