Onefinity with windows xp/vista/7/8

Sorry for my english it’s not my mother language.
I am a beginner i try a cnc for the first time.
I haven’t found answer in the forum.
I try to connect my woodworker with windows xp.
The wifi is off.
When i put http://OneFinity.local in internet explorer, i have this page.
Could you help me?

Salut Fred11,

plutôt ancien ton navigateur :slight_smile:

The fact that the page title was successfully transmitted suggests that the web browser is for some reason not able to render the page

Your operating system is over 20 years old, its support ended 2014. You could try to install the firefox web browser. HTML has evolved a lot in the last twenty years.

Can’t you install a recent operating system and web browser on your computer?

What about connecting a HDMI monitor, a keyboard and a mouse to the Onefinity Controller?

Welcome to the forum!

Now that I have recovered from suffering a technology PTS episode, I suggest using or borrowing even a used mobile phone or tablet.

1 Like

Hi Aiph5u
That’s what I thought.
I have try to instal the last internet explorer but it doesn’t work.
For the new operation systeme, i an not sure that my old pc accept it.
I need one that is light, maybe a linux.
I have a other pc much much recent but, it has no ethernet port.
For the hdmi monitor, my machine is Is in a garage where I do other work, not terrible level of dust and sparks.
But if it doesn’t work with the my old pc, I will find another solution.

1 Like

Hey Fred11,

you are right, there are many Linux distributions that run on older hardware. At the moment I recommend using the desktop-live image of Devuan, it uses the graphical Refracta installer which is much more pleasant and easier than the standard installer. I was surprised how pleasant it is, and installation goes very fast with it.

However, installing a Linux-based operating system usually comes with more learning than with other operating systems. But there is a large support community.

Yes I know, today’s laptops and tablets are so thin that the Ethernet port doesn’t fit anymore. But that’s no problem, for very little money you can get a USB-to-Ethernet Adapter. I use them a lot.

1 Like

I have a docking station for the new pc. I tested it with my woodworker, it doesn’t work.
Maybe a used computer would be the solution

Hey Fred11,

which has an ethernet port, I assume?

What you need for the “Onefinity.local” addressing to work is that an implementation of zeroconf is running on your computer. On your older computer from which you showed the photo above, this was obviously the case, since the page title was transmitted successfully.

What operating system and version is running on the new pc?

If the old computer is 20 years old, many recent Linux distributions will work fine on it. I run both very old and totally new computers, one that still runs 24/7 absolutely reliably since twenty years is from 1994.

1 Like

Yes she has an ethernet port.
The new is with windows 11, but it’s not a good idea, i doesn’t want it in the garage.
I will find one with windows 7 minimum and with a ethernet port.

So this this morning I tried several things.

  • connects directly to a pc more recent with windows 8 , it doesn’t work
  • create a dhcp server in this , it doesn’tt work
  • connect a screen, keyboard and mouse, it ok

Am i doing something wrong or the link with the pc has a problem?
Good question
The leds are lit on the ethernet sockets

Hey Fred11,

You can try if it worked by typing ‘ping onefinity.local’ or by logging in into the Onefinity Controller via ssh with username ‘bbmc’ and password ‘onefinity’.

Apple Mac OS and MS Windows have supported link-local addresses since 1998. A link-local address is an address that is assigned automatically without any configuration.

1 Like

Can you tell me more.
The ping is in cmd?
How to connect with ssh?

Hey Fred11,

yes, type “ping onefinity.local” on the CLI

The output should look similar to this:

root:~# ping onefinity.local
PING onefinity.local ( 56(84) bytes of data.
64 bytes from onefinity.local ( icmp_seq=1 ttl=64 time=0.441 ms
64 bytes from onefinity.local ( icmp_seq=2 ttl=64 time=0.468 ms
64 bytes from onefinity.local ( icmp_seq=3 ttl=64 time=0.420 ms
64 bytes from onefinity.local ( icmp_seq=4 ttl=64 time=0.456 ms

or, if the link-local connection is not there:

root:~# ping onefinity.local
ping: onefinity.local: Name or service not known

The link-local ( connection should also appear with

netstat -r

Best “SSH Clients” for Windows

1 Like

The ping and netstat-r doesn’t work windows xp or windows 8.
I will watch for the ssd.

On the other hand surprise

That was with the old old pc (xp) only a display problem I think. Ihave only put a other cable.
If I arrive at the same thing with the pc windows 8, It will be ok Ithink

Hey Fred11,

What do you mean, “doesn’t work”. Did the ping tell that “onefinity.local” is not known, and netstat -r did not list a network?

Do you connect the Onefinity Controller and the PC(s) directly? And do you use a CAT5 or higher Ethernet over twisted pair cable?

If ping and netstat -r do not show a network, trying ssh will help you nothing.

This looks like the HTML on the Onefinity Controller page is too recent for the totally ancient web browser. But as I already said above, the link-local connection works with this computer, as it already successfully submitted the HTML page title before. But you should not try this with such an old web browser.

Have you tried the Firefox web browser? If you choose the correct Firefox version on this download page, you can install it on your older Windows PC.

Can you tell which processor you have? Do you have 64-bit Windows?

If you look at the Firefox system requirements, you see it works with Windows 7 and above. When Internet Explorer was Windows’ web browser, the free and open source Firefox managed to implement the most recent HTML standards better.

1 Like

First thank for your assistance.

For netstat -r I am an idiot, I didn’t put the space. I will try it tomorow as quickly as possible.
For the ping the same thing.

For the cable honestly I don’t know , I took cables from my home cinema to test.
In the first cable it is written "data cable FTP flex 4pr 120 ohm patchable 7x0.16 category 5 ff2498, in the second no description.

I have CAT5e cable and sockets to make a new cable. I can make a crossover cable or a straight cable, if I understood correctly a crossover cable is better

For the old browser, yes I know. The old pc with xp is too old and wild be stay for my children.

I bought yesterday one pc with windows 8 it is an acer aspire with intel celeron cpu1005m @ 1,90 ghz 64 bits.

I tried firefox on it

1 Like

Hey Fred11,

Category 5: This cable is the right one.

Since the advent of Auto MDI-X in 1998, a crossover cable is no more necessary.

Did you install a recent version of firefox? Does it display the Onefinity Controller page correctly?

A new cable tested in a an other systeme it s ok.
The pc with windows 8.

http://OneFinity.local in firefox “page no found”

netstat -r

ping onefinity.local
“could not find the host”

You were able to directly see the screen with a monitor hooked up to the onefinity controller right? If so you should be able to see the IP address it is using. In the 1.09 software it is right near the top of the main screen. Try pinging that from your laptop. That avoids the zeroconf use of onefinity.local. If that ping works, give that IP address as the URL instead.

1 Like

I would try a different browser such as firefox and definitely use the IP address of the controller, it should be visible on the LCD touchscreen.

1 Like

Hey Atroz, hey Giancarlo @Tuvix72, hey Fred11, hey all,

but if you mean a 169.254.x.x address, this is a zeroconf address, a link-local address. And the link-local network ‘’ is shown successfully with ‘netstat -r’ on the original poster’s computer, as he showed above, which means, the computer is ready to find computers that support link-local addresses (like the Onefinity Controller).

The addressing with the host name “onefinity.local” uses Name Service Discovery, this is done by LLMNR under Windows, but this function is present in all Windows releases since Windows Vista, so of course should be present on Windows 8.

1 Like