WIFI Connection Problem

I have purchased a pi USB wifi dongle
Have connected to the controller and linked to my wifi
I have an IP showing on the onefinity of 169.254.8.175 when i tried earlier i had an IP of 192.168.1.250
The onefinity is showing on my hub manager as connected on 2.4ghz with the IP address the same as displayed on the onefinity
I have typed the IP into the address bar of my browser but it just keeps whirling round and doesn’t connect i have tried microsoft edge and google chrome
Any help would be great
D

Hi Darren,

I might be misunderstanding something, but did your 1F not come with built in wifi? I’m wondering why you are using a USB wifi card?

Either way, I suggest finding the IP of the computer you are using to try and access the controller. You will need the controller and the computer to be in the same network, unless you have to customized routing going on, which is unlikely for a home setup. If you have established that both the controller and the computer are on the same network, try to ping the controller. If that is successful, but you still can’t access the website your networking should be fine but you have a different problem.

Hi Ryan
My Onefinity did come with wifi but i am a distance away from my router in my workshop, thats why i opted for the dongle USB Wifi Adapter for the Raspberry Pi | The Pi Hut
I can see from my router manager app that both the laptop and Onefinity are on the same network
Also dont understand why i get a 169 ip address
Thanks
D

Gotcha. 169 addresses aren’t real, they are sort of a troubleshooting code. It means the NIC cannot reach or acquire an IP from the DHCP server.

Do you have the ability to set the IP manually on the controller for the USB wifi? If so try that, mimicking the info from your computer but use something different for the last number set, like 164 or so. You will probably need to set the gateway and DNS as well which are also on your computer’s settings.

Hi Ryan
After disconnecting everything and rebooting i now have a 192.168,1.250 IP address but when i enter it into the address bar of microsoft edge it just keeps whirling round i have gone to the command prompt and pinged the IP and it comes back with no issues
I am totally lost

Each new network interface will have a unique IP address. Did you disable the on-board WIFI? It is possible the RPI is connected with both interfaces which would cause some problems.

You can check your interface and signal strength with the following command: iwconfig. To enter the command, plug a physical USB keyboard into the controller and do the following procedure:

1 - Hold down the CTRL key and press, T then C (make sure CTRL is down the whole time).
(this will open a command window)
2 - type iwconfig and press return

3 - it should output something like this:

wlan0     IEEE 802.11bgn  ESSID:"ssid of my network"  
          Mode:Managed  Frequency:2.452 GHz  Access Point:*******   
          Bit Rate=72 Mb/s   Tx-Power=1496 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          Link Quality=39/70  Signal level=-71 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

Look for the signal level in the middle of the report - it should be between -30dbm and -90dbm. -30 is perfect signal strength (100%) and -90 is essentially no signal strength (0%).

Alternatively, you can do something like this:

sudo iwlist wlan0 scan | egrep “Cell|ESSID|Signal|Rates”

But that will only give the info for wlan0, which like almost certainly the on-board WIFI. You can sub wlan1 for wlan0 if that is the name of your secondary interface.

When you are done, simply type exit on the command prompt and you will be returned to the kiosk window.

If you want to stop or start the wireless interface, open the command window and do this:

sudo ifdown wlan0
sudo ifup wlan0

If you have more than one wireless interface, use the appropriate interface name.

Hope the helps.

-Tom

2 Likes

Tom

Thanks for the reply

Wlan0 fairly matches yours with my ssid and a signal level of -61

There is also a Wlan1 but its showing no access point

Both of them are the one single dongle i am using which is a IEEE802.11

Could it be a setting on my laptop?

Thanks

Have you tried “onefinity.local” instead of the IP address??

Also, I would force it to HTTP (no ‘S’) like: http://onefinity.local or http://192.168.(fill in rest of IP here)

Darren - wlan0 is usually the internal WIFI, not the a dongle. I am still using internal WIFI. If you want to use the dongle exclusively, you might need to disable internal all together. According to the google you can use:
sudo iwconfig wlan0 txpower off
to turn off the internal WIFI. There are other ways as well. You can also use ifconfig to list all devices to make a more informed decision.

-Tom

I plugged in this: https://www.amazon.com/gp/product/B08F2ZNC6J/ref=ppx_yo_dt_b_search_asin_title?ie=UTF8&psc=1 and made no changes to the 1F, and have had great luck with wifi connectivity - it was really plug-and-play.

Also, you can SSH to the 1F, username “bbmc”, password “onefinity” (ssh bbmc@onefinity.local should do the trick) to get access to the PI operating system.

I can also confirm this, I plugged in an Edimax brand WiFi dongle with a Realtek chip that is compatible with raspberry pi, and on reboot it replaced the internal WiFi as wlan0.

Before I plugged it I , I made sure that the internal WiFi was connected to my router and that I could at least ping it, and the Google DNS to ensure connection.

I also did an iwlist scan on wlan0 so that I knew what the “before” looked like. As expected it shows the hardware capabilities of the internal WiFi chip, as well as signal strength and connection quality. As expected, with the WiFi router less than 10 feet away, I had a 50/100 signal strength and 72/100 quality of connection. Also pay attention the the available link speeds for the internal hardware. 48MBs connection is the fastest, this is another reason for the slow connection.

I plugged in the external dongle and did an ifconfig to confirm the new dongle was recognized, and it showed up as wlan1. Before rebooting I did an iwlist scan on wlan1 and it confirmed that it was the external dongle, 95/100 signal and 100/100 quality. Also showed the link speed capability of 300MBs, much better than the internal hardware.

It that point I rebooted, and somewhere somehow the internal pi programming loaded the external dongle as wlan0, which is what the controller software is set up to use for its connection.

I again confirmed with an iwlist scan of wlan0 that it was using the new hardware, and the internal WiFi was not listed anywhere.

I would like to add that I did intentionally try to add both hardware to the wpa_supplicant files, in order to use both connections, but it seems that the buildbotics controller does not keep the changes persistent. I checked that my changes were saved before rebooting but after reboot any file changes I made were gone.

I hope this helps others have a little better understanding of the WiFi on this controller.

Kris

2 Likes