WIFI Connection Problem

I have purchased a pi USB wifi dongle
Have connected to the controller and linked to my wifi
I have an IP showing on the onefinity of when i tried earlier i had an IP of
The onefinity is showing on my hub manager as connected on 2.4ghz with the IP address the same as displayed on the onefinity
I have typed the IP into the address bar of my browser but it just keeps whirling round and doesn’t connect i have tried microsoft edge and google chrome
Any help would be great

Hi Darren,

I might be misunderstanding something, but did your 1F not come with built in wifi? I’m wondering why you are using a USB wifi card?

Either way, I suggest finding the IP of the computer you are using to try and access the controller. You will need the controller and the computer to be in the same network, unless you have to customized routing going on, which is unlikely for a home setup. If you have established that both the controller and the computer are on the same network, try to ping the controller. If that is successful, but you still can’t access the website your networking should be fine but you have a different problem.

1 Like

Hi Ryan
My Onefinity did come with wifi but i am a distance away from my router in my workshop, thats why i opted for the dongle USB Wifi Adapter for the Raspberry Pi | The Pi Hut
I can see from my router manager app that both the laptop and Onefinity are on the same network
Also dont understand why i get a 169 ip address

Gotcha. 169 addresses aren’t real, they are sort of a troubleshooting code. It means the NIC cannot reach or acquire an IP from the DHCP server.

Do you have the ability to set the IP manually on the controller for the USB wifi? If so try that, mimicking the info from your computer but use something different for the last number set, like 164 or so. You will probably need to set the gateway and DNS as well which are also on your computer’s settings.

1 Like

Hi Ryan
After disconnecting everything and rebooting i now have a 192.168,1.250 IP address but when i enter it into the address bar of microsoft edge it just keeps whirling round i have gone to the command prompt and pinged the IP and it comes back with no issues
I am totally lost

Each new network interface will have a unique IP address. Did you disable the on-board WIFI? It is possible the RPI is connected with both interfaces which would cause some problems.

You can check your interface and signal strength with the following command: iwconfig. To enter the command, plug a physical USB keyboard into the controller and do the following procedure:

1 - Hold down the CTRL key and press, T then C (make sure CTRL is down the whole time).
(this will open a command window)
2 - type iwconfig and press return

3 - it should output something like this:

wlan0     IEEE 802.11bgn  ESSID:"ssid of my network"  
          Mode:Managed  Frequency:2.452 GHz  Access Point:*******   
          Bit Rate=72 Mb/s   Tx-Power=1496 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          Link Quality=39/70  Signal level=-71 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

Look for the signal level in the middle of the report - it should be between -30dbm and -90dbm. -30 is perfect signal strength (100%) and -90 is essentially no signal strength (0%).

Alternatively, you can do something like this:

sudo iwlist wlan0 scan | egrep “Cell|ESSID|Signal|Rates”

But that will only give the info for wlan0, which like almost certainly the on-board WIFI. You can sub wlan1 for wlan0 if that is the name of your secondary interface.

When you are done, simply type exit on the command prompt and you will be returned to the kiosk window.

If you want to stop or start the wireless interface, open the command window and do this:

sudo ifdown wlan0
sudo ifup wlan0

If you have more than one wireless interface, use the appropriate interface name.

Hope the helps.




Thanks for the reply

Wlan0 fairly matches yours with my ssid and a signal level of -61

There is also a Wlan1 but its showing no access point

Both of them are the one single dongle i am using which is a IEEE802.11

Could it be a setting on my laptop?


Have you tried “onefinity.local” instead of the IP address??

Also, I would force it to HTTP (no ‘S’) like: http://onefinity.local or http://192.168.(fill in rest of IP here)

Darren - wlan0 is usually the internal WIFI, not the a dongle. I am still using internal WIFI. If you want to use the dongle exclusively, you might need to disable internal all together. According to the google you can use:
sudo iwconfig wlan0 txpower off
to turn off the internal WIFI. There are other ways as well. You can also use ifconfig to list all devices to make a more informed decision.


I plugged in this: https://www.amazon.com/gp/product/B08F2ZNC6J/ref=ppx_yo_dt_b_search_asin_title?ie=UTF8&psc=1 and made no changes to the 1F, and have had great luck with wifi connectivity - it was really plug-and-play.

Also, you can SSH to the 1F, username “bbmc”, password “onefinity” (ssh bbmc@onefinity.local should do the trick) to get access to the PI operating system.

1 Like

I can also confirm this, I plugged in an Edimax brand WiFi dongle with a Realtek chip that is compatible with raspberry pi, and on reboot it replaced the internal WiFi as wlan0.

Before I plugged it I , I made sure that the internal WiFi was connected to my router and that I could at least ping it, and the Google DNS to ensure connection.

I also did an iwlist scan on wlan0 so that I knew what the “before” looked like. As expected it shows the hardware capabilities of the internal WiFi chip, as well as signal strength and connection quality. As expected, with the WiFi router less than 10 feet away, I had a 50/100 signal strength and 72/100 quality of connection. Also pay attention the the available link speeds for the internal hardware. 48MBs connection is the fastest, this is another reason for the slow connection.

I plugged in the external dongle and did an ifconfig to confirm the new dongle was recognized, and it showed up as wlan1. Before rebooting I did an iwlist scan on wlan1 and it confirmed that it was the external dongle, 95/100 signal and 100/100 quality. Also showed the link speed capability of 300MBs, much better than the internal hardware.

It that point I rebooted, and somewhere somehow the internal pi programming loaded the external dongle as wlan0, which is what the controller software is set up to use for its connection.

I again confirmed with an iwlist scan of wlan0 that it was using the new hardware, and the internal WiFi was not listed anywhere.

I would like to add that I did intentionally try to add both hardware to the wpa_supplicant files, in order to use both connections, but it seems that the buildbotics controller does not keep the changes persistent. I checked that my changes were saved before rebooting but after reboot any file changes I made were gone.

I hope this helps others have a little better understanding of the WiFi on this controller.



So I ordered the dongle recommended t https://www.amazon.com/gp/product/B08F2ZNC6J/ref=ppx_yo_dt_b_search_asin_title?tag=benmyers-20

I put it in my controller and had nothing but trouble first it showed 2 ips one with 192 and one with 169. Reading these posts make it seem like it will resolve itself which for the life of me I can not see how. I have tried for over an hour to get this working. Now when I try to put it in it is not recognized at all. Any help appreciated.

despite what some people have said, no usb dongle works in the onefinity controller. (unless you ssh into the controller and change code (this is not standard practice and not covered under warranty). Perhaps they’ve experienced a placebo effect.
You’re router/extender must be within 10 feet with clear line of site to the controller.

@onefinitycnc I so appreciate you posting on this helps to have official notice, even though that dongle was stated as plug n play it was not. There are at least 4 other posts also claiming plug n play for dongles.

I have ordered https://www.amazon.com/gp/product/B08F2ZNC6J/ref=ppx_yo_dt_b_search_asin_title?tag=benmyers-20 which is only a few bucks more and like most with a rolling table have power under the table so this seems like an excellent solution to the connection problems.

Again, NO usb dongle will work, none. So you might as well cancel that order.

You need an extender to move the signal closer to the controller, like this:

1 Like

Has anyone used an RJ45 to Wireless adapter. Seems like a much easier and more reliable solution. That said, my wireless works fine so I have not used this on the 1F.
I used a similar one years ago on a PC and it worked fine.

10 feet because the Wi-Fi antenna on the Pi is buried inside an Al box?

Yes. And the pi doesn’t have an antenna.

It’s a little patch antenna on the PCB isn’t it? There is no external antenna or connection for one.

Some have hacked the Pi3 to add an external antenna, but doing so voids the type certification of the device and voids the warranty of the Pi3.

I mentioned this dongle in an earlier post but have now received one and actually tried it on my Onefinity X50 Woodworker.

My WiFi connection was solid at first but started getting intermittent. I didn’t feel like pulling another Cat5 cable in the shop so I ordered an IOGear Ethernet-2-WIFI adapter ($39 on Amazon, other sites I looked at were more expensive). This dongle plugs into your ethernet (RJ45) cable connection on the controller and converts it to a 2.4GHz wifi signal. It’s like putting an antenna outside the controller box. You can turn off the wifi in the controller because it now uses the wired port as a wireless interface. There is no need to deal with drivers or USB power issues on the controller. It does draw power from a USB cable but a power supply is included.

I configured the dongle using my shop computer before connecting it to the 1F controller. It only took a couple of minutes and it seems to be working great so far. FYI - I am using the latest 1F firmware v1.0.9. My router is only about 20ft from my 1F so I can’t really comment on the effective range. The marketing stuff says up to 100M inside.
Maybe an easier option for you guys having trouble with WiFi.