Wifi connection problems

I’ve just finished setting up my new 1F and now I’m trying to set up a wireless connection to the machine. I followed the steps for wifi setup, selecting client mode and entering the SSID/password and rebooting. No luck. Reading what I can to troubleshoot the problem I learned the small antenna in the Rasberry Pi requires a strong wifi signal. Since my 1F is in in the basement and the wifi router is on the second floor it makes sense that might be the issue (although my iPad connects to wifi without any problem in the basement). Fortunately I have a hotspot router (Mofi 4500) that I set up next to the 1F controller for testing purposes. After doing the 1F setup for that router again I had no luck in connecting. The next thing I tried was to run an ethernet cable from the hotspot router to the controller, which did work! And I was then able to successfully connect to the controller from my iPad and control the 1F.

The fact that I had a wifi router physically 2 feet away from the controller seems to negate the issue of the signal not being strong enough. I’m wondering if perhaps it’s a problem with wifi in the controller? I don’t know what else to do. It’s impractical for me to run an ethernet cable down from the 2nd floor or leave the hotspot router in place next to the 1F, so I really need to get wifi working. Does anybody have any suggestions about what else I can try? TIA

I had to put a wireless repeater within 1’ to get it to work. Silly as it may be, try moving it closer.

If that didn’t work, my plan was to connect by ethernet to the wireless repeater. Not all of them have it, but many do have ethernet ports. Until an external WiFi adaptor is supported I think this is the best route.

Garrett, thanks for the quick response and helpful suggestions. Per your experience I tried moving the router nearer the controller in several positions (as close as 6 inches) and still no connection. This reinforces my feeling that something is wrong with wifi in my controller.

Your idea of getting a repeater with an ethernet port is an awesome one. I think that will be the solution I need. Thanks much!

The raspberry pi has a quite small antenna, and here it’s located inside a metal box, so it has a lot working against it. Best to treat this like a wired machine only, and if you get signal you are lucky.

This is the extender I am using, which has an ethernet port. Pretty inexpensive.

TP-Link AC750 WiFi Extender (RE220), Covers Up to 1200 Sq.ft and 20 Devices, Up to 750Mbps Dual Band WiFi Range Extender, WiFi Booster to Extend Range of WiFi Internet Connection https://www.amazon.com/dp/B07N1WW638/ref=cm_sw_r_cp_api_i_Qa0JFbT03GJ8P

Perfect. I’m ordering one today. Thanks again for your help.

  1. I learned the hard way that there is no space in my SSID name. 2. Onefinity has stated it won’t work if you try to connect to 5Ghz on your router.

Fortunately my router is in the garage with the OF

I ultimately purchased a wifi repeater (per garrett1812’s suggestion) and ran a cable from that to the controller. That completely fixed the connectivity problem and is now 100% reliable. I do not have any spaces in my SSID name (I do have a dash however), and was originally trying to connect at 2.4Ghz - all without any luck. The controller seems happiest with a wired connection.

Mentioning the requirement to connect at 2.4 GHz and omitting spaces in the SSID name is helpful info for others wrestling with wifi connectivity issues…

1 Like

So, My day job is actually engineering Wi-Fi networks. I have a pretty elaborate Wi-Fi setup in my house and I still couldn’t get it to connect unless it was right next to the Access Point. These machines use a small enough amount of data that the “repeater” (We call them Wireless Mesh) with a cable is likely the better option.

Metal actually reflects magnetic waves. So, having the metal box around their Raspi is a surefire way to make the signal terrible. Definitely something for the OF team to consider on future designs. they either need to find a way to make an antenna that goes on the outside of the box or allow USB wireless cards.

I’m just lucky I have a bunch of demo access points that I can use.

2 Likes

My question is about the poor WIFI connections, as the controller was built on the Buildbotics framework I looked there. They suggested using a USB extender/antenna attached to a USB port and unchecking the tick box for the internal WIFI connection. 1F doesn’t seem to have this feature to uncheck but it seemed like a good solution. anyone have any thoughts on the subject.

You can do a search on the topic and find a number of posts. The consensus seems to be to move a wifi extender close to the controller and hope it’s strong enough to overcome the effect of the faraday cage the controller has created around the internal wifi antenna.

The other favorite fix is one of these:

There is some discussion about how there isn’t quite enough room for all the USB connections you’ll need if you’re using a thumbdrive for files and if that’s the case attaching a USB hub and then put your USB devices including this one in the hub will take care of that problem.

If you get a wifi extender, connect it directly to the controller using an ethernet cable. Works great for me.

1 Like

I have the router in the garage connected through the cat 5. One day it works flawless, one day it doesn’t connect, one day works a bit on and off then perfect then…

After doing more research on the subject I think I’ll stick with using my laptop and an ethernet direct connection to the controller. The USB WIFI option on the Raspberry pi board isn’t automatically recognized and requires a substantial of machine level code via the PI terminal to be added for this function to work. I’m afraid I would mess it up and completely kill my controller. Might be different if it were plug and play. Buildbotics added this option but it appears 1F opted out

Since this is a software option and easily added it would be nice if 1F did so in the next version update

2 Likes

Especially since they did such a nice job if shielding the internal antenna :grin:

I have no option for Internal WIFI, running 1.0.8 firmware

Hope, that’s what I paid all this money for? Hope?

Hope is not a plan. Don’t remember who said that but it’s true.

The issue with the USB ports being crammed so close together is a ‘feature’ of the Raspberry Pi, not much Onefinity or Buildbotics can do about it. The ‘feature’ persists even into the Pi 4.

I know this is an old thread but I am just getting my machine setup so all these undocumented ‘features’ are new to me. So I get to complain a little bit too. Sorry if it’s redundant but that’s how it goes sometimes.

No need to vent to me, I was just reporting the consensus of the forum members.

Personally, I don’t have the issue. I have the controller in a cabinet I made with 1/2" plywood walls. It’s in my garage. Altogether it’s about 25 ft from my wifi router. There’s a steel door between the garage and the entry room that has the router in it.

So it’s not universal that the wifi in the controller won’t work. It apparently may depend on the quality of your router and wifi network, not just the controller’s wifi chipset.