Is my controller about to die?

So last night when I turned on my cnc it took a considerably longer time to to boot(4 to 5 times the normal) and then the wifi was no longer working.

I tried rebooting, no luck. I tried reentering the wifi info. No luck.

Any suggestions? Someone suggested reflashing the SD, holding off on that option for the moment. Onefinity Support thinks it’s a network issue. Even though the network has been working on the same location and configuration since I owned the machine.

I’d second the idea of re-imaging the SD card, boot time would be tied to the RPI and OS. You could get a new 32gb micro sd card and image that if you don’t want to affect your existing card.


I am experiencing very similar issues. Long boot times, long time for a computer to connect to the onefinity. Finally I reached out to onefinity when I could not connect to Wi-Fi. Got the same stuff about the controller needing to be 10’ and line of sight to the router even though everything has been working fine for about two years now.

I unplugged the controller power cord and forgot about it for about 10 min. I plugged it back in and started the machine and everything worked. But I am still experiencing longer than normal boot times and longer than normal times for my computer to connect to the onefinity.

I am starting to lean toward the need to reflash the operating system….

I bought an new SD card just haven’t had a time to test it out yet.

I’m amazed the WiFi works at all. The Raspberry Pi PCB board has the pads for an antenna connector, but the commercial modules don’t populate them in order to meet FCC regulations. There’s a tiny antenna made out of PCB traces (must be pretty low gain). Put this inside a metal box and you’re gonna have problems. I have ethernet running to the shop but the WiFi access point is 40’ away from where the 1F is going to live. It will be a pain to run an ethernet cable but doable if I have to. Or I might try one of the external Raspberry Pi WiFi adapters.