Onefinity Weak Wifi Reception

New owner here. I am a technology guy by trade and noticed right out of the gate the weak wifi reception for the 1F. Raspberry Pi’s have small antennas and weak reception as they are, but now they’ve been wrapped in a metal box which seems to limit reception to a very, very small range. One option that 1F touts is a repeater. However, from a technology perspective, repeaters are terrible and should be avoided in your network at all costs. Yes, they can work sometimes, but usually not reliably.

I saw another post where someone added an external antenna to his box and that seems to work, although most of us don’t have that kind of know-how to do that without wrecking the board.

My suggestion is to find a wireless gaming adapter and plug it in the ethernet port on the back. It is technically a bridge that connects to your wifi and bridges traffic over to 1F. I had an old Linksys WGA600N laying around and it works great. Range is outstanding and once configured to connect to your wifi, you just need to plug it into your 1F. I haven’t tried it, but I bet a USB wifi adapter would work fine too.

1F, you should add a USB wifi adapter or external antenna to the next version of machines. The cost is negligible and will greatly increase usability.

I am a new owner with the same issue I have added a usb wifi adaptor from the rpi shop and it still hasn’t improved things the wifi to my workshop is full strength
I am waiting for a carrier to deliver a 25m ethernet cable so I can try a hard wire temp fix to try to get things working, i cant have a wire permanently due to the layout of the house and workshop its more than a bit frustrating

I had a similar problem and ran an ethernet cable from my 1F to my wireless router. Still can’t connect to the controller. I’ll be curious what people have to say. I haven’t found much on this subject.

On the Onefinity display in the upper left hand corner under the logo does it show an IP address for your controller? If it does enter that IP address into your web browser on your computer. If not there could be something wrong with the cable run, you can try plugging in another device like a laptop and see if it receives and IP address from your router.

I had three issues: (1) distance, signalled reached but I guess not strong enough, (2) foiled lined installation on my shed (3) 1F metal cage.

I laid 100 meters of network cable to my shed (I still find it hard to call it a shop). It’s not too expensive (in the scheme of things), easy to wire up, replaceable if it gets damaged but doesn’t help my get fit campaign (the walks back n forth to reload the USB, to get the USB which i always left behind). I tried the TP Link type mains extensions with intermittent joy.

Derek, Thanks but yes I have the IP address. I reviewed the video from Onefinity and haven’t found much more. Networks are my downfall… I may have a firewall issue but haven’t been able to figure it out.