Controller Troubleshooting

My home network extends to my workshop via a buried cable conveying telephone and ethernet. Last week a nearby lightening strike must have leaked enough voltage to the underground cables that several interconnected devices were damaged even though the lights never went out. Unfortunately, at the far end of the chain of interconnected devices was my CNC controller.

The fan comes on when power is applied, the inline fuse is intact, but no video signal and the stepper drivers never come to attention. Before I bite the bullet on purchasing a new controller, do any of you have a checklist for a guy and his multimeter to see if there is a replaceable component rather than a whole new controller?

The Ethernet port on the controller is part of a Raspberry Pi. While your conclusions make sense, I’m curious if you have tried to SSH in, just to be certain the port or Pi is dead.

If the Pi appears to still function, you might try reflashing the SD card.

1 Like

Hey John,

just in case the Pi should be dead, the Raspberry Pi 3B (not plus) is a replaceable part.

If the fan runs, the +5V Voltage on the AVR Mainboard is there which means the voltage regulator on the board was not roasted.

2 Likes

Thanks. SD flash was already tried. Baby needs new shoes, papa needs new controller. Poor baby.