Delay between the start of the spindle and the start of work

Hello everybody.
I finished installing my new spindle today and I tested it.
Everything is OK
I realize that the work starts at the same time as the spindle.
I would like the work to start only when the spindle has reached its working speed.
Is it possible?
Now I press play to start, pause for the spindle to go up to its working speed and play again to start the job.
I know that you can modify certain startup parameters on a recurrent basis.
I thought there was probably a solution here.
I may have searched badly but I didn’t see anything on it.
Can you help me?

Hey Fred,

which CNC controller do you use, the Onefinity Controller or the Elite/Masso? If the first, yes, you can add a G4 (Dwell) command in the ‘program-start’ and then of course also at the end of the ‘tool-change’ field on the SETTINGS page.

The command goes

G4 P3

where “5” is the number of seconds you can change to your needs.

Hi Aiph5u
You are a precious support. :smiley:
I use the derivative of buildbotics.
You mean the “3” rather than the 5?
Ok I will try next time.

Hey Fred,

yes… The correct value depends on the individual spindle and the target speed, just try it out! :wink:

You can add dwell or pause for user input in both vectric and f360.

I did that, but it’s not good. The program waits to start but the spindle also, do I have to add M 0 between G 17 and G 4?

Like this is good.

1 Like

Hey Fred,

you are right, the command only makes sense after the M3 command. My fault. It’s the duty of the g-code program to give the M3 command at the right moment, so it is the best, as @AndyP already mentioned, to let the CAM program to insert it. Also M3 command only works when S has been set. If S is 0, M3 does not start the spindle.

1 Like

No problem.
I’m very happy to have found it alone even if it’s not much.
I feel like I understand what I’m using. :laughing: