[solved] Starting spindle with RS485

Is anyone using the breakout adapter to connect to your VFD over RS485? I’m connecting to a VFD that’s not in the dropdown so I have set up custom modbus commands and it seems to work except when I run a job. When the gcode does s18000 m3, the spindle starts, but the controller does not wait for the spindle to come up to speed before starting the milling. I’ve looked through some of the Buildbotics source code and I have yet to find the code that should wait for the spindle to reach the desired speed before proceeding. I’m hoping someone else has it working and can share some log output so I can compare with mine.

I did some more research and found this gem:

So, how do people deal with this problem today? Is there a way to put some sort of pause in the gcode?

G4 P6 works around that problem.

While testing this, I discovered another problem. When there is a rapid traverse to move to the next cutting position, the controller sets the speed to 0, does the rapid, then sets the speed back to 18000. The gcode only has one S command, so I’m pretty sure this problem is on the Buildbotics firmware.

Just found this in the source code:

"rapid-auto-off": {
  "help": "Turn tool off during rapid moves.  Useful for LASERs.",
  "type": "bool",
  "default": false

I haven’t figured out how to set this. I don’t see it anywhere in the UI.

Tool screen… Checkbox

Yes, it is on the Tool screen, but only when you select PWM for the tool. When I selected that, the box was checked. I unchecked it, then switched back to custom VFD. That fixed the problem. I’ll open an issue for this part.

1 Like


1 Like