Problem starting spindle on RS485 com signal via Breakout board

Hello everyone, Newbie here.
I have upgrading my 1F to a 220V 2.2KW spindle with a HY VFD and it works great manually using the digital display, but, I Can not get the spindle to run on RS485 via Gcode from the 1F controller via pin 13 and 14 on the breakout board. I have made all the command input changes on the VFD and 1F control panel to run the Huanyang spindle. I’ve checked and rechecked the wiring and setup, No luck. Has anyone else had this problem, and if so what is the fix.

Which vfd are you using?

Double-check connectivity through the wiring (my VFD needed an ethernet connector, and making sure the wires were in the correct channel was a fiddle).

Check that VFD doesn’t need a switch across two of its normally closed terminals.

Check that VFD doesn’t need a momentary close across two terminals - a type of reset.

Check the usual baud rate, parity settings etc.

Check you have set up for Modbus RTU.

…there’s probably more

Remember to do this without the spindle attached. Vfd will operate (led display) without the spindle - this is the safest way.

@BryanHunt and I have posted a couple of vfd set ups in the forum. @MyersWoodshop has also done a couple of YouTube videos

Thanks for the response, My VFD is model #HY02D223B, with a 2.2KW spindle. And, Yes, those videos are very useful I followed all the steps for setup ( 1 Mod Bus ID,9600Baud and 8 bit, no priority RTU and RS485…But with no luck. I checked the #13 and #14 on the breakout board and on the VFD all are connected correctly. and the VFD is set on the correct parameters. also, the onefinity (1F) controller is setup from the correct Huanyang spindle, all I get on the 1F is a timed out notice in the tool menu, and NaN on the speed, so it must not be talking…
Have you herd of any others having this problem?

Are you getting “disconnected” / “timedout” messages? .(i forget what the exact message is in the controller screen). Or just no spindle spinning.

Buildbotics manual says: " * Check the ‘connection’ field in the tool configuration. If the connection is “Disconnected”, verify wiring between the Buildbotics Controller and the VFD is correct. If the connection is “Timedout” verify the register settings in the VFD and confirm that the ‘bus-id’, ‘baud’, and ‘parity’ settings match those in the VFD."

VFD set up can be very frustrating, just done it myself recently. It’ll be something annoying.

Are you uk based?

I’m Getting a “timeout” in the tool configuration. onefinity tells me the settings to program in the VFD. I’ll recheck the settings, but after that I’m Not sure what to do next. thanks for your help.

Agree, timeout is a connection problem. For me it was wiring (but only after I fiddled with settings did I decide that, then only after running conductivity tests on the wiring.).

I don’t have the same vfd as you. The one you have sounds quite popular so others may be able to help. I figure you are using a canned configuration. You could try customising your configuration in case the canned one isn’t using the correct addresses.

Perry B, did you ever fix your issue? I am experiencing the same thing.

I am also getting a timeout, status 0, speed NAN
I can run the spindle manually with the keypad, when I put it in manual mode, so I know the spindle part is correct, just the comms are off.

I select Huanyang VFD in the dropdown. I’ve tried reversing polarity on the RS485 input (shouldn’t matter, but someone else mentioned that.)

Hey Smoothbore,

Have you checked this?

That did it. I wouldn’t have though that would have made a difference, but it did. Turned out that I just wasn’t getting a good connection on that DB-25. What really did it was just pulling those mounting screws almost all the way out, pushing on the connector and verifying visually that it was all the way down–then screwing in the connector hold-down screws.

In case anyone wanted to know: Amazon purchased Huanyang 110V 2.2KW spindle with VFD package. Setup was really pretty simple. This forum is really great. Thanks All!

4 Likes