Spindle connection help

I’ve setup my vfd and spindle. Set all the parameters to the correct values. Connected the breakout board to the vfd. But when I go to the tool section on my screen and setup the spindle thru that it keeps saying timed out and won’t show connected. Does anyone know a way to fix this?

1 Like

There’s 2 places you have to set up parameters. On the VFD, a few registers need to be set for the RS485:
PD002 - 2 (enables RS485)
PD163 - 1 (1st inverter)
PD164 - 1 (9600 b/s)
PD165 - 3 (8N1)

Then, you need to set the controller correctly to let it know you have a spindle. It should look something like this:

Lastly, pins 13/14 on the breakout board need to get connected to the RS-/RS+ on the VFD.

When it’s all set right, you get an “OK” on the connection. You can enter commands into the MDI screen to startup the spindle (M3 S18000), and stop it (M5).

Being careful with the above worked for me - how much of this have you been through?

I’ll double check everything when I get home but I believe I have everything set the same way.

So I just went back thru all the setting and even did a rest on the controller and redid them and it’s still going back to timed out

Yuck - mine worked the first time. I don’t have the tools to troubleshoot the RS485 signal - a simple voltmeter won’t work. You’re down to trying to figure out if the controller is sending the right signal, or the wire isn’t sending the signal to the VFD, or the VFD isn’t interpreting it correctly. You could try contacting 1F support, but they don’t officially support spindles. An oscilloscope or swapping parts might be the next step.

Thanks for the quick response. I’ve put in an email to ther support team. I’m hoping it’s just a simple fix. I’m trying to do a parameter reset on the vfd but for some reason it won’t reset. The book says to change pd013 to 8 and it should reset them all but it never says end after I press set. Have you ever done a reset

I have not done a reset myself - but ‘08’ on PD013 should do the trick.

Unlock vfd config first
PD000 SET 0 SET – UNLOCK VFD CONFIG

I got it to reset and then went back thru and reentered all the parameters. Still not connecting. For now I’m just going to control rpms from the vfd and get to cutting after I play with it a while I will try to connect again and see if I can make it work

Ensure that your breakout board is fully tighten (use the hand screw to fix it). Mine did not connect when I first plug it to test. It took me few time to get it work.

Then compare your PD settings using this:
note: you can skip section ‘Configuration to trigger SSR’.

[link] (Information to build you own Onefinity Companion Control Box - #21 by blaghislain)