Huanyang VFD to Controller

I have everything connected and all components work. What I can’t seem to get working is the connection between the vfd and the controller.

I have the two wire rs485 connection done but I keep getting a timedout on the controller. I rolled the wires and somewhere it changed to CRC error.

It’s only a simple 2 wire connection on pins 13&14. I tried a standard db25 connector ($2) with no success. Then I bought a onefinity db25 connector with the same result ($35 later). I believe I have the latest firmware in the controller as well.

Anybody have any suggestions?

Hey Steve,

  • Did you already edit the settings “Source of Operation Commands” (PD001) and “Source of Operating Frequency” (PD002) to 2?

  • Did you already edit the VFD settings in the Tool Configuration Tab?

  • Did you already follow all instructions in

  1. Connecting a Huanyang VFD
  2. Huanyang User’s Manual
  3. How to connect a Spindle using RS-485
  4. How To Install A CNC Spindle - Part 1 - YouTube
  5. How To Install A CNC Spindle - Part 2 - Wiring To The Controller - YouTube
  6. Recommended Huanyang Configuration
  • The environment around Power Motors and Power Electronics is dirty and can cause EMI. Did you ensure to at least use a twisted pair cable when connecting the RS-485 ports?

Thank you very much for the links and the suggestions. I do believe I’ve tried everything. I have all the settings exactly as you stated I even went to some additional settings that were listed in a related link.

When none of those work I reverted back to the internet on at least four more videos. I finally went to PD013 and factory reset the vfd.

Reentered all the settings and the vfd still shows timed out. I put two plus hours in tonight with no success.

If I change pd001 and 002 back to default, I can hit run and the vfd will spin the spindle. I’m just zero success for getting the controller to control the vfd.

Any suggestions would be helpful I’m starting to think that maybe I should try a different vfd, but that’s an expensive try…

And I metered the voltage on the vfd rs485 terminals and get 2.7 volts DC as well as 2.7 volts on the correct pin 13 and 14 at the controller. I believe 13 is positive and 14 is negative. Sorry I sound unsure but I’ve triple checked it I’m losing my mind and just scrambling for options.

I used my multimeter to test the continuity of the breakout cable that I bought from onefinity and pin 13 and 14 correspond exactly as they should between the vfd and the controller.

I use RS485 protocol for many systems that I work on for my profession. I am a low-voltage contractor of 26+ years and I am highly opinionated that it’s not a cable issue. Twisted shielded cable for a length of 2’ is not necessary. I can try it, but I have watched countless videos of others who were successful and used whatever/ random, individual, single conductor cable and theirs works. Not twisted, not shielded. Again, when something doesn’t work, you’ll try even the smallest of things just to see if it works.

1 Like

Hey Steve, hey all,

Note that with the VFD Yuyong YL620A, it turned out that A and B were reversed. Just to mention it.

One thing is, since the old days of DFÜ with modems, I know serial lines need to be terminated. My VFD has its Termination Resistor on-board, it can be activated with a DIP switch. I do not know whether the Onefinity Controller or the Huanyang VFD have such a Termination resistor built in.

actually I would not measure DC but AC or better use an oscilloscope, and I would measure when initiating communication.

Are you using the VFD’s RJ45 connector?

One question: How did you connect ground between the VFD and the controller? Are you using GND pin on the breakout board adapter?

Sure, I know, but you can never know what specific EMI you have in your place

What do you exactly mean with you “rolled” the wires?

Very good point and thank you. It’s time to break out my resistor stash. Another very good viewpoint that most rs45 requires termination on both ends. The source on the device.

I’ll give that a try and report back

Some termination requires positive to negative connections. Meaning that transmit plus will go to transmit minus and receive plus will go to receive minus. Also referred to as rolling the two cables.

Not many combinations you can make when it’s only two wires. Thanks for asking the question because it’s really helpful to get this much support.

1 Like

Very true. I will purchase whatever small amount to give that a try as well I don’t own it

One Yang instructions don’t clearly show a ground terminal other than what I would interpret as the DCM? (digital common). So my ground is connected in the controller but floating in the vfd until I can identify the correct common terminal to link the two together.

As for my RJ45 or ethernet connection it is connected to my home network and I can control it via a web interface. I’ve connected through it through my iPad as well as through my laptop now that is on my network.

As RS-485 serial line is a balanced connection it does not need a common ground, but if there is faulty grounding in the system i.e. ground loops, this may induce hum which can deteriorate signals.

1 Like

There’s nothing in any one of the diagrams that references sharing a ground between the vfd and the controller that’s the odd part

Although it is not needed I would have assumed that they would have at least wanted a common ground source between the two

Hey Steve,

Iv’e been thinking of this too, I’m about to wire my control cabinet too.

(Source: Omron MX2 User’s Manual)

Since the Onefinity Controller has a protective earth (PE) connection to its case, and the VFD too (at least mine, your VFD too?), they are both earthed and bonded.

I’m also having this issue, modbus timedout with no spindle control, spindle and vfd work fine when set to be controlled via VFD buttons. All settings to communicate with the onefinity controller and shielded cabling are correct.

My VFD has a white case and the settings are displayed as F001, F002 rather than PD001, PD002 etc but all settings are the same. There’s also some jumpers visible on the vfd, jumper 4 seems to relate to RS485, it has a setting of ON or OFF, I have tried it on both, still no joy. At a loss to know what’s wrong.

Hey Jason,

it may be a jumper for the Termination Resistor like my VFD has? I could only say that by looking at the pcb. You don’t have a manual?

I assume you have set
PD000 to 0 (unlock parameters)
PD001 to 2 (Command source is RS485)
PD002 to 2 (Speed source is RS485)
PD163 to 1 (Communications address 1)
PD164 to 1 (9600 b/s)
PD165 to 3 (8 Bit, No Parity - RTU)

Did you try to change the Interface settings e.g. go up to 19200 Baud (PD164=2) or to 38400 Baud (PD164=3)? Ensure that the setting in the Onefinity Controller’s Tool Configuration Tab is set to the same Baud value as in the VFD setting.

Thanks for your reply, I hadn’t tried changing the baud rate when I posted but I have just tried it now without any success.

I can’t find the exact VFD drive manual but it is the same drive as this one, just badged different

Here is the part about J4, I’ve tried it both on and off.

I don’t really understand rs485 to well and I am presuming I have used a suitable cable. Its 3 core CY 0.75mm shielded, I have not connected the earth or the shield either end. Trying to see if this is correct is a minefield searching Google with lots of conflicting theories about connecting the shield and/or earth core one end to a GND terminal (not PE?), both ends and not at all, totally confusing.

Distance between VFD and onefinity controller is only around 6 inches but the cable is about 4ft in length, not coiled up.

As a test I reset the OF controller to factory setting ith the breakout board unplugged, then configured the TOOL for the VFD. This gave me the exact same timedout message on the OF screen, whether this means it is a cabling issue for sure I don’t know :man_shrugging:

Hey Jason,

thank you for sharing your information. I downloaded the Manual for my collection (I collect information in order te be able to write a wiki entry on spindle and VFD setup).

So my assumption was right, the DIP switch “J4” is the termination resistor. If you have only one VFD connected, then it is on one end of the RS-485 network, so the Termination Resistor should be turned on.

As for cable, the RS-485 Connection is a balanced line which does not need a common ground but in order for the shield to work it must be connected to ground somewhere. In order to avoid ground loops, shield may be connected on one side only.

I would connect it to the VFD’s case which in turn should be connected to the PE of your workshop wall outlet. It has a PE connection I hope? Your VFD has a PE connector as it sais in the manual on page 7:

Earthing terminal
VFD housing earthing terminal must be earthed.
Note: Screws on main control board serve as PE terminals for that of 0.4 ~ 1.5kW.

Also the Onefinity Controller is earthed, it has a PE pin and I assume that it is correctly connected to the case, so the case should be earth.

You may also connect the shield to the “Shield” pin of the breakout board adapter.

I really hope that the RS-485 connection can be made to work.

Did you already try to swap 485+ and 485-?

Looking on builbotics they say connect shield both ends, one end to GND of VFD and other to pin 25 breakout, maybe I should try this. I didn’t try swapping + and - as the OP above said that did not work.

Edit: not pin 25, the GND pin on the DB25 connector!