VFD Modbus "timedout" problem

I’m trying to get my Huanyuang VFD with Modbus over RS485. I get “timedout, status 0, speed NaN” and I’m running out of ideas.

The Timeout is always present, even if I disconnect the breakout board. Is this normal behavior for the controller?

So far I have tried:

-Checked all the settings in the VFD and 1F a million times.
-Resoldered the connector of the breakout board.
-Measured the A and B connection between the 1F PCB motherboard to the VFD.
-Switched place of the RS485 A and B connector
-Tried diffrent addresses and baud rates

Any ideas?

Thanks in advance!

Hey Henrik,

This indicates that at the serial port of the Onefinity Controller, there is nothing that answers.

Note that the forum is full of answers dealing with exactly this question. There is a search function above.

Welcome to the forum!

You are on pins 13 and 14 on the breakout board?

You have PD001 and PD002 set to use RS485?

PD163 set to the same MODBUS address as you have set on the Onefinity?
PD164 set to 9600 baud?
PD165 set to 8N1 for RTU?

1 Like

May I add
PD070 ANALOG INPUT set to 0-5V

Is PD070 used when using MODBUS? I was thinking it was only for PWM mode.

Hey Yvon,

the analog and digital inputs are ignored for spindle on/off and spindle speed when the VFD is set to ModBus mode. However if you have a VFD with a broken serial interface, you could fallback to control via analog voltage input (for speed) and digital terminals (for spindle on/off) control (which is how the MASSO controllers control the VFD).

1 Like

Thank you! I scoured the forum before creating this new topic. That’s where the list of my failed tests comes from. :slight_smile:

Yes, 13 and 14.

PD001 -2
PD002 -2

PD163 -1 (same in the 1F controller)
PD164 -1
PD165 -3

I followed the instruction from this:

This solution never entered my mind! Thank you very much! :smiley:

According to the Buildbotics manual (v1.0.2) there are three Modbus states:

  • Disconnected - The VFD is not connected to the Buildbotics Controller or the wiring is incorrect.
  • Timedout - The VFD may be connected to the Buildbotics Controller but communications has not been established. The likely cause is the bus-id, parity, or baud rate do not match or the registers are not set correctly in the VFD.
  • Ok - The communications link is working properly.

My controller is always “Timedout” no matter if the cables (pin 13/14) are connected or not. Could someone please confirm if the current Onefinity firmware responds with Disconnected or Timedout when no connection exists between the controller and VFD?

Looks good to me.

I think I did come across a thread here where others had trouble with RS485 and fell back to analog voltages. Fortunately mine worked.

Hey Henrik,

the Onefinity Controller offers PWM output that you get at the corresponding pin and that is adjusted with the PWM settings on TOOL page. It is usually needed by PWM spindles.

Besides ModBus and Analog 0-10 V input, my VFD also has a PWM input. If your VFD has only analog 0-10 V voltage input but no PWM input, you need a PWM to voltage converter module. Take care to choose one that works with 3.3 V PWM input.