ModBus Error Message - "CNC Error"

I am running a Woodworker X-50 with a Huanyan HY-series (2.2KW, 220V) VFD with the suggested matching Huanyan spindle. I’m using the 1F Breakout Board Adapter (pins 13 & 14) to communicate over the RS485 bus to control the VFD/spindle via the 1F controller. I’ve configured the 1F Controller and the VFD as needed and everything has been working without issue for the past several months. Two days ago at the end of an otherwise normal carve the spindle moved to the home point, but then continued to spin when it would normally spin down to zero. I had to use the stop button on the VFD to stop the spindle as even the MDI would not respond to an M5 command. Over the last couple of days it seems the RS485 communication has continued to degrade to where now when I run a program the spindle may start spinning or it may not. If it does start spinning, it will not stop at the end of the program. I’ve checked the continuity of the wires running from the corresponding contacts on the VFD all the way to the pin 13 & 14 contacts and through the Breakout board to the female receptacles that plug into to the back of the 1F controller. The continuity is solid no matter how hard I wiggle/push/pull on things. I don’t have an oscilloscope so I can’t watch the actual RS485 commands. When turning the 1F controller on and then checking the ModBus on the TOOL page (no program running) the status seems to randomly switch between “OK” and “TIMEDOUT” (explaining the flip of a coin as to whether the spindle starts or not). However, twice now it has shown “CNC ERROR” for approximately 0.5 to 1 sec and then switched to “TIMEDOUT.” I’ve searched the forum but can’t find any reference to a “CNC ERROR” message for ModBus. I’m beginning to wonder if it is trying to tell me something is wrong with the 1F controller. Any ideas for troubleshooting or direction to information sources would be greatly appreciated. For now I’ve switched the VFD back to manual mode and it is working perfectly to include controlling an IOT switch for the spindle cooling pump. With the exception of the ModBus switching, the 1F controller seems to be working normally also. Thanks for your help!

Did you try replacing the RS485 cable? Are you using shielded cable, twisted unshielded, or none of the above? If shielded, is the shield connected to device ground?

Hey Lowkey,

you could check your controller for two reported connectivity issues:

  1. There can be connection problems with the breakout board adapter not reaching the contacts inside D-Sub connector on Onefinity Controller due to too long jackscrews on the D-Sub connector

  2. More recently there was a problem reported with the D-Sub connector soldered into Onefinity Controller Mainboard, problem could only be resolved by resoldering the solder joints on D-Sub connector pins on Onefinity Controller Mainboard :frowning:.

1 Like

Hi Matticustard, thanks for the reply. Short answer is no I have not tried to replace the RS485 cable yet. The wire that has worked for the last couple months with no issue is single strand, unshielded, insulated 18 gauge copper wire. Since I hadn’t touched (literally) the wiring configuration before this started, I’m a little suspicious that all of a sudden it is the wire, but you never know. When I installed the VFD/spindle I replaced all the 1F control cables and the spindle power cables with shielded cable and connected all the shields to ground. I’d like to understand what the “CNC Error” message is trying to tell me before I go changing the wiring. 1F support doesn’t have any documentation on the ModBus error messages since they don’t support VFD/spindle configurations. They did provide a link to the Buildbotics user manual and I’ll see if I can find anything in there about the “CNC Error” message.

Hi Aiph5u, thanks for the reply. I did see this reported issue in the forum and tried my D-Sub connector both with and without the screws while holding firm pressure on the connector to ensure it was fully seated with no apparent affect on the problem. The ModBus status continued to randomly cycle between OK and TIMEDOUT with the two noted “CNC Error” messages. I checked the soldering of the D-Sub connector itself and tested the continuity from the wire connector through the board to the female receptacle side of the D-Sub connector. All checked out normally.

I also saw this issue in the forum. I’m not quite ready to tear into the controller mainboard yet unless I’ve exhausted all other options and understand what the “CNC Error” message is trying to tell me.

Hey Lowkey,

are you sure you don’t mean “CRC Error” instead of “CNC Error”? There exists no such error in the source code. But if you have CRC Errors, this does mean that the data on your serial line get corrupted. I would strongly recommend to check your wire and its connections.

Note that single strand wire is for permanent, fixed installation only and not suitable for applications where movement is expected (for example, if the cable hangs freely and could be bumped, or if there is still trial and error with the positioning of the components of the installation, or if the machine is occasionally disassembled. Also, single strand wires should always be secured to the underlying surface with nail clamps). Better use twisted pair, shielded, stranded wire with cross-sectional area according to your VFD manual (e.g. 0.14–0.75 mm² / 28–14 AWG) with matching wire ferrules and correct wire ferrule crimp pliers (e.g. wire ferrule crimping pliers from Knipex or crimping die for insulated and non-insulated wire ferrules for the Crimp System Pliers for exchangeable crimping dies (version with case) (version without case) or the PreciForce® Crimping Pliers or the Crimping Pliers for two-hand operation). Note that wire ferrules for wires smaller than 0.25 mm² can only be crimped by Self-Adjusting Crimping Pliers for wire ferrules.

Also if your VFD offers an internal termination resistor (my VFD does) then it’s good to turn it on, because expectedly your VFD is the last device on the line.

Further Reading

Modbus RTU frame format

1 Like

Hi Aiph5u, I think you are probably right that it is “CRC” vs. “CNC”. Small screens, old eyes and short display duration of the message makes it highly likely I misread the screen.

I agree. I was lazy and got away with the single strand wire for a couple of months, but obviously it isn’t working now. Working to replace the two RS485 wires with a twisted pair, shielded, stranded wire of the appropriate cross-section.

Not sure about this. Will have to dig into my owners manual to see if it has one.

Thanks again for all the help and resources! I will be out of pocket for the next couple of weeks and won’t get a chance to tinker with the wiring until I get back. I’ll update the thread once the wiring is replaced. I really appreciate the time you’ve taken to provide the information!!


I finally got the ModBus working again. I replaced the original wiring with twisted pair, shielded, 18 gauge strand wire and grounded the shield to the VFD ground. However, this alone did not solve the problem. I still had a TIMEDOUT message after the wire change.

After reading through some more posts I noticed some folks had success after swapping the RS485 + and - wires around. I was careful when I originally wired things up to not get things swapped, but I tried it anyway and the ModBus began working.

In trying to figure out what was going on I noticed the VFD manual showed the RS485 + and - ports one way and the label over the ports on the VFD was reversed from the manual. When I wired things up I assumed the label on the VFD was correct (didn’t think I needed to crosscheck the manual). I can’t explain why things worked for several months with the wires swapped, but if you are having ModBus issues crosscheck the manual versus the label on the VFD to see if the wires are going where they are supposed to.

Thanks to Aiph5u for all your suggestions and time! I appreciate the help.