Zhong Hua Jiang CNC Spindle,110V 1.5KW and H100 VFD. Need Modbus settings

Hi Everyone,
I have the Zhong Hua Jiang CNC Spindle,110V 1.5KW and H100 Series VFD. I am trying to input the correct Modbus settings into the Onefinity controller so I can control the speed of the spindel and have it turn on/off when the job starts and when it is done using the Onefinity controller. Any help would be really appreciated.

Hey Mike,

there exists a search function in this forum. Using it would have allowed you to find the answers yourself,

  • e.g. here for the VFD ModBus settings,

and

  • here to make the speed dial on front panel functional.

Note that a VFD is a device that is meant to be enclosed in a cabinet.

I did do a search first and did find the one you pointed to, but it is for a different VFD and those settings don’t work on mine. But thanks for taking you time.

Hey Mike,

these settings didn’t work?

Creating a custom VFD and spindle

[…]

Settings for 8. Creating a custom VFD program:

Command Address Value Comment
max-freq-read 5 0 Maximum operating frequency
freq-set 513 0 Set frequency in 0.1Hz
stop-write 512 0 Stop
fwd-write 512 1 Run forward
rev-write 512 5 Run reverse
freq-read 544 0 Read operating frequency
status-read 528 0 Read status
disable

Hey Mike,

I don’t think it’s different internally. In the controller source code, H100 and V70 are identical. You can have a look at it yourself, it’s open source.

And as reported, this user got his H100 to run with the settings shown above, he just had temporary errors due to insufficient cable shielding.

And this user also had success with getting his H100 to run with these settings.

That some VFDs are identical with others is often the case. Hitachi WJ200 and Omron MX2 are practically identical, and Hitachi S1 and Galt G200 are practically identical too.

Hope you report how it goes on.

Okay I guess I did not try the one in the above post, but will try it later today or tomorrow and will let you know how it goes. Thanks for letting me know about the cable shielding, I would have never guessed that. So do you know what wires need to be shielded and what you shield them with if that does become a problem for me?

Thank you so much for helping me with this and will keep you updated.

Hey Mike,

most important to shield is the cable from VFD to spindle. This is because the currents the VFD produces are by no means nice sine waves, they are a heavy source of EMI.

You can find some information about wiring a spindle and a VFD in the following threads

Regarding spindle cable, I always strongly recommend to buy it ready-to-use with the spindle from the spindle manufacturer. Reputable spindle manufacturers always offer this. Unfortunately many cheap chinese spindle/VFD kit vendors offer only a loose plug and a piece of cable for making the spindle cable yourself, but I can not recommend this. In the case one’s budget allows only for a cheap chinese spindle kit, I know you can buy a spindle cable ready to use here.

Next thing to have shielded is the VFD enclosure, called control cabinet, as explained here.

The cable for the ModBus communication between VFD and CNC Controller finally is a signal cable. It should be a …

For a good connection it’s good to use wire ferrules as mentioned here

1 Like

Hi Aiph5u,
I did everything and I am still getting a timeout. So first in the Onefinity Tool Configuration in the tool-type I am using the Custom Modbus VFD because mine is not listed. As you can see from the images, I have the correct settings and getting a failure at 0 max-freq-read 5 0. I also included a screen shot of the thread that you shared with me showing the correct VFD settings and I made sure these were correct on my H100 VFD. Let me know what you think the problem is.

Thanks,

Mike



I had to switch around the two wires between OF controller and VFD to get rid of a Modbus error. Have you tried that?

1 Like

When you say OF controller, do you mean the Breakout Board Adapter?
If that is what you are talking about, are you using number 13 and 14? or 15 and 16?

Thanks,

Mike

Hey Mike,

I would check cabling of the signal wires and if they have a good connection.

I would check if there is the issue with the breakout board adapter which was reported here. It’s about the breakout board adapter not getting any or no proper connection to the pins of the Onefinity Controller because the screws/sockets of the DB-25 connector/breakout board adapter prevent that.

As Martin @MVall already suggested, some users also had success with switching the two signal wires around.

You can also experiment with altering communications speed. This sometimes can help if the line is noisy. But you got to have matching values on Onefinity Controller and VFD:

Onefinity Controller
baud
VFD
F164
4800 0
9600 1
19200 2
38400 3

Hey Mike,

Precisely.

13 and 14, as explained here.

References

I just tried switching the two wires on the Breakout Board Adapter and that did not change anything. I am using #13 and #14 on the Breakout Board Adapter, this is what the manufacture said to use.

Here is an image of the Breakout Board Adapter:

Hey Mike,

did you check if you have this issue (already mentioned above)? Does it work after you removed the nuts (A) of the DB-25 Port, as mentioned in that post?

Yes, that was what I did as well. Sorry that didn’t do it for you. Just didn’t want you to miss a potentially easy fix.
But @Aiph5u has some good further suggestions to try in his link re connections, cables, etc. Hope it works out eventually

Yes I did and it also made no difference, I even checked the continuity of the breakout board and it was good.
Question: I was told by the Zhong Hua Jiang that I should use #13 and #14 on the breakout board for the wires coming from the VFD, do you use the same? I have read once to use #15 and #16.

Thanks,

Mike

Hey Mike,

yes, of course, 13 (RS385 A) and 14 (RS385 B). You got to have them connected to 485+ and 485- on the VFD (I linked you to the exact I/O port docs above).

But you don’t know where did you read that? Pins 15 (“tool enable”) and 16 (“tool direction”) just switch on and off a non-VFD spindle. Pin 15 (“tool enable”) is used by many users for a relay to switch their hand trim router on and off.

Your VFD however is also able to be controlled by these pins. You could use that as a fallback solution if you cannot get the ModBus communication to work. In the Onefinity Controller, you would choose “PWM spindle” as “tool type” and wire pin 15 (“tool enable”) to one of the programmable multi-function inputs of your VFD and the Onefinity Controller would be able to switch on and off the spindle by g-code commands or by a g-code program, similarly as it would if connected over the ModBus communications port. As for spindle speed, it could be controlled by pin 17 (“tool PWM”) if you buy a PWM-to-Control-Voltage converter and connect it to the 0-10 V analog speed input of the VFD. You got to program these ports and modes accordingly inside your VFD. This is described in your VFD manual.

By the way, this analog control voltage is the way how the MASSO CNC Controllers control a VFD, since MASSO controllers don’t have a ModBus communications port :frowning:.

One user reported the problem (which persisted) was with the DB-25 connector soldered into Onefinity Controller Mainboard, and where the problem could only be resolved by resoldering the solder joints on DB-25 connector pins on Onefinity Controller Mainboard :frowning:.

Unfortunately some users reported in the past they did not get the ModBus connection to run at all. This exclusively applied to cheap chinese VFDs though. There can be many reasons why it fails, some of them can be found, others not. However I encourage everybody who wants to run an induction motor (=spindle) on their CNC rather than a hand trim router that sets your workshop on fire :slight_smile:

1 Like

Definitely frustrating when you can’t get the core functions to work. @Aiph5u is obviously very knowledgeable and has helped a number of people here with VFD issues, so you may well be in the territory of defective products, either the OF internal board, the VFD, or possibly even your signal cables somehow.
Don’t know how much further you want to go down this road, but you could still play with the baud rate (communication speed) if you haven’t yet. One user randomly got things going that way. @Aiph5u gave you the info above.
Otherwise, if you’re able to get your hands on a different VFD to test, that would another step.